Bug 814628 - XML-RPC(-509): Unable to make sense of XML-RPC response from server.
XML-RPC(-509): Unable to make sense of XML-RPC response from server.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
: 818784 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 05:54 EDT by Mikhail Veltishchev
Modified: 2013-02-25 21:36 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:14:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail Veltishchev 2012-04-20 05:54:03 EDT
Description of problem:

Cannot submit particular bug report.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Try to submit it via RH Bugzilla
2. Got the error
  
Actual results:
Cannot submit crash report

Expected results:
Report should be submitted successfully.

Additional info:
--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
fatal: XML-RPC(-509): Unable to make sense of XML-RPC response from server.  XML-RPC response too large.  Our limit is 1048576 characters.  We got 1048780 characters.  Use XMLRPC_TRACE_XML to see for yourself
(exited with 1)
Comment 1 Mikhail Veltishchev 2012-04-20 05:55:40 EDT
Seems this bug is very similar to #666893.
Comment 2 Nikola Pajkovsky 2012-04-20 06:15:02 EDT
commit 29fc07758fa0aaef5f066091faee56280cf7500e
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Fri Apr 20 12:13:58 2012 +0200

    xmlrpc: rising XMLRPC_XML_SIZE_LIMIT_DEFAULT up to 4 times
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 3 Johannes Postler 2012-04-28 11:44:37 EDT
I'm experiencing the bug too. Anything I can do to help?
Comment 4 Nikola Pajkovsky 2012-05-04 03:34:22 EDT
*** Bug 818784 has been marked as a duplicate of this bug. ***
Comment 5 Nikola Pajkovsky 2012-05-04 03:36:03 EDT
install nightly builds of btparser, libreport a abrt and test as much as it is possible ;)
Comment 6 Fedora Update System 2012-12-20 03:54:04 EST
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
Comment 7 Fedora Update System 2012-12-20 04:44:38 EST
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17
Comment 8 Fedora Update System 2012-12-20 20:28:09 EST
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-01-11 20:14:55 EST
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-02-25 21:36:58 EST
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.