Bug 814666 - client3_1-fops.c: Log enhancements
client3_1-fops.c: Log enhancements
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
pre-release
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: GlusterFS Bugs list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 07:13 EDT by Sachidananda Urs
Modified: 2014-04-17 07:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:38:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-04-20 07:13:14 EDT
The path mentioned in the below logs says: <gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11

Should be fixed to print the path.


[2012-04-20 03:39:25.299323] W [client3_1-fops.c:2610:client3_1_lookup_cbk] 0-nfs-test-big-client-3: remote operation failed: Stale NFS file handle. Path: <gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11
[2012-04-20 03:39:25.299617] W [client3_1-fops.c:2610:client3_1_lookup_cbk] 0-nfs-test-big-client-2: remote operation failed: Stale NFS file handle. Path: <gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11
[2012-04-20 03:39:25.299659] W [client3_1-fops.c:2610:client3_1_lookup_cbk] 0-nfs-test-big-client-1: remote operation failed: Stale NFS file handle. Path: <gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11
[2012-04-20 03:39:25.299732] W [client3_1-fops.c:2610:client3_1_lookup_cbk] 0-nfs-test-big-client-0: remote operation failed: Stale NFS file handle. Path: <gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11
[2012-04-20 03:39:25.299745] W [nfs3.c:1198:nfs3svc_lookup_cbk] 0-nfs: 2ef49f73: <gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11 => -1 (Stale NFS file handle)








Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2012-05-08 07:06:45 EDT
CHANGE: http://review.gluster.com/3274 (protocol/{client,server} : Log improvements) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 2 Kaushal 2012-05-08 07:12:44 EDT
The above change doesn't actually solve this. Had put in the wrong bug-id for review. The change solves https://bugzilla.redhat.com/show_bug.cgi?id=812199 and https://bugzilla.redhat.com/show_bug.cgi?id=809713.
Comment 3 Amar Tumballi 2012-05-10 02:10:45 EDT
Sac,

The path printed in the log, is actually directly accessible in the backend, and also, with the current design it is very hard to print the exact path itself (as there will be no path passed in the fops).

Hence not planing to work on this bug. This will be properly documented to help GSS and users to understand which file is the one in backend.


for "<gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11" backend path will be "$export-path/.glusterfs/fd/d3/fed32419-4222-4bb2-a8b7-e036df090dfd/linux-3.2.11"

So taking it off the 3.3.0beta blocker state.
Comment 4 Sachidananda Urs 2012-05-21 03:40:11 EDT
(In reply to comment #3)
> Sac,
> 
> The path printed in the log, is actually directly accessible in the backend,
> and also, with the current design it is very hard to print the exact path
> itself (as there will be no path passed in the fops).
> 
> Hence not planing to work on this bug. This will be properly documented to
> help GSS and users to understand which file is the one in backend.
> 
> 
> for "<gfid:fed32419-4222-4bb2-a8b7-e036df090dfd>/linux-3.2.11" backend path
> will be
> "$export-path/.glusterfs/fd/d3/fed32419-4222-4bb2-a8b7-e036df090dfd/linux-3.
> 2.11"
> 
> So taking it off the 3.3.0beta blocker state.

Yes, makes sense.
Comment 5 Niels de Vos 2014-04-17 07:38:32 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.