Bug 81484 - No jars files in the Open Office default installation (maby java support broken)
No jars files in the Open Office default installation (maby java support broken)
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2003-01-09 15:44 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-12-05 14:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
OO 1.02 error message (21.31 KB, image/jpeg)
2003-04-13 07:39 EDT, Need Real Name
no flags Details
output on rombuild -ba (35.25 KB, text/plain)
2003-12-08 12:36 EST, Patrick Pollet
no flags Details

  None (edit)
Description Need Real Name 2003-01-09 15:44:30 EST
Description of problem:

There are no jar files in the default OpenOffice installation. This means that
there is no way to connect OpenOffice with the java UNO components.

I think that the whole java support is broken in OpenOffice. In fact, I have
tried to connect OO to PostgreSQL throught JDBC but it complain no java
installed. I have tried only the pagkages in the default download version of Red
Hat Linux 8.0, so I don't know if in the packaged version with the extra office
cd there is an rpm with the java bridges to UNO.

This is not really a bug, just a missing feature, but still important.

Version-Release number of selected component (if applicable):

How reproducible:
Install all the OpenOffice packages, jars still missing

Steps to Reproduce:
1. Install Open Office
2. No jar files are installed
Actual results:
The default instalation of OpenOffice from OpenOffice.org contains some jars
needed to perform UNO connection, they are missed in the OO shipped with RHL
8.0, download edition

Expected results:
Jar files available to OpenOffice

Additional info:
Comment 1 Jakub Jelinek 2003-01-09 15:53:26 EST
Until Sun or IBM opensources their JDKs, or until it builds with GCJ,
there is nothing we can do about this. The distribution must be self-hosting.
Comment 2 Need Real Name 2003-01-23 07:40:04 EST
Sorry if reopen this bug report.

What you say is right, and the OO base setup should remain self hosting, but I
really don't understand the need of removing _any_ reference to java in OO.

In OO there are some helper files and programs (no java programs but C++
programs that don't need a java VM to run) that are used to configure the java
uno components.

They are, for example:



The only files that need a java VM are those in the classes directory.

You can provide a separate contrib rpm for these files, or can require that we
try to get the classes from some other resource, but setting up the environment
is really difficult without these helper programs.

Java UNO is a great way of providing office solutions for OO, and for Linux, and
you are stopping this opportunity (we can count on an Office solution that works
just out of the box).

We would offer (and we are preparing) Office solution based on Red Hat Linux,
Java and Open Office, but we cannot, due to the usefulness of the program
shipped with OO. They are Open Source and compile with gcc, so I really don't
understand the need of these removal...

Please, understand the importance of java in Open Office. This is not a problem
of classes (that can be compiled using jikes, after all, but even jikes was
removed form RHL 8.0...), only a problem of being able to install the classes
and the classpath, have to run a single program (jvmsetup) and go on with the work.

We are unable even to connect OO to postgres, without java (we have the ODBC
bridge, surely, but in a java environment this is not the best way of doing

Hope you'll help us in the next RH release...

Comment 3 Need Real Name 2003-04-13 07:39:32 EDT
Created attachment 91105 [details]
OO 1.02 error message
Comment 4 Need Real Name 2003-04-13 07:41:24 EDT
   Unfortunately, this has not been done with RedHat 9.0 with OO 1.02.
   /opt/openoffice/program/classes directory is still missing
   and /opt/openoffice/program javaldx, jvmsetup are just wrappers
    that returns errors...

    So I still get the fatal errors : unable to load libjvm.so when accessing
  JDBC data sources....and OO dies. BTW everything works ok in RH 7.3 
   and we uses the very same setup and JDK.

   Besides, ODBC support in RedHat 9.0 is now broken. Was OK in RedHat 8.0...
   After installing unixODBC and MyODBC (either 2.50 or 3.50), connections
    to ODBC datasources now fail with the following error:
        Cannot open lib /usr/lib/libmyodbc.so: /usr/lib/libmysqlclient.so.10
        Symbol error version GLIBC_2.0 not defined in file libc.so.6 with
         link time reference...

    So database access in RedHAT 9.0 is not working at all 
    and only via ODBC in RedHat 8.0....
    until the next update of glibc, I suspect.

Comment 5 Dan Williams 2003-12-05 14:26:36 EST
It is not appropriate to require Java to build OOo, when you are
deploying on a platform that does not have Java.  That completely
defeats the purpose of mandating that the package builds on the base
system that Red Hat or others distribute.  Therefore, Java support
will not be included and cannot be.

This will not be fixed with 1.0.x series builds.

_However_, with the 1.1.0 series RPMs (soon available for RH9), I have
modified it so that you can simply throw a switch in the specfile,
point the specfile towards your JDK, and roll your own Java-enabled
build.  In the mean time, Red Hat is working on getting GCJ to build
relevant parts of OOo.  But until that time, RH will not be
distributing Java-enabled builds, so you must either build it yourself
or wait for GCJ support.
Comment 6 Patrick Pollet 2003-12-06 10:14:23 EST
  That's what I tried to do on a Fedora workstation, following instructions given  
in the Fedora devel list  
I downloaded openoffice.org-1.1.0-6.src.rpm 
removed the --disable-java in the spec file 
removed all no-solar patches  
It first warning me about libart not being the correct version and later  
 the build failed  with an error about a 'LinuxEnv' file not found . 
I get the same error trying to build with the original spec file ... 
So I guess I shall wait for source that you annonuced  
in the Fedora list. 
Comment 7 Dan Williams 2003-12-06 16:15:59 EST
1.1.0-8 should be in Rawhide as of Friday.  You'll see an "enable_java" switch at the 
top, and a path to the JDK right below it.  This was tested on Fedora with the Sun JDK 
RPM from java.sun.com.  The path listed there should be the default path to that 1.4.2 
JDK if installed from RPM.
Comment 8 Patrick Pollet 2003-12-08 12:36:16 EST
Created attachment 96403 [details]
output on rombuild -ba
Comment 9 Patrick Pollet 2003-12-08 12:39:41 EST
hello again, 
   Unfortunarely, rpmbuild -ba dies with the follwing error: 
dmake has been successfully built 
+ '[' 1 -gt 2 ']' 
+ '[' 1 -gt 1 ']' 
+ exit 0 
Exécution_de(%install): /bin/sh -e /var/tmp/rpm-tmp.90055 
+ umask 022 
+ cd /usr/src/redhat/BUILD 
+ cd oo_1.1_src 
+ export LANG 
+ unset DISPLAY 
+ rm -rf /var/tmp/openoffice.org-1.1.0-root 
+ mkdir -p /var/tmp/openoffice.org-1.1.0-root/usr/lib/openoffice 
+ RESPONSE_FILE=/usr/src/redhat/BUILD/oo_1.1_src/rsfile.ins 
+ cd ./instsetoo/unxlngi4.pro/01/normal/ 
/var/tmp/rpm-tmp.90055: line 32: cd: ./instsetoo/unxlngi4.pro/01/normal/: No such 
file or directory 
+ cp -f solver/645/unxlngi4.pro/bin/regcomp 
cp: cannot stat `solver/645/unxlngi4.pro/bin/regcomp': No such file or directory 
erreur: Mauvais status de sortie pour /var/tmp/rpm-tmp.90055 (%install) 
I am enclosing the full ouptut of the process. 
I am on a freshly installed Fedora, with 20 Go disk free and and fully patched with 
apt-get dist-upgrade and jdk1_4.02 installed. 
Sorry ;-(( 
Comment 10 Dan Williams 2003-12-08 12:47:56 EST
Please grab 1.1.0-9 which fixes this issue.  Either that, or change the 
[ $RPM_BUILD_NCPUS -gt 1 ] to be a [ $RPM_BUILD_NCPUS -ge 1 ] and
rebuild.  1.1.0-8 is broken for single-processor builds.
Comment 11 Dan Williams 2003-12-08 13:30:09 EST
See bug 111623 for more build failure info.

Note You need to log in before you can comment on or make changes to this bug.