Bug 814914 - [ath5k] Wireless unavailable at random
[ath5k] Wireless unavailable at random
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 06:02 EDT by Boricua
Modified: 2012-12-03 07:33 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 07:33:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Messages log (2.28 MB, text/plain)
2012-04-28 06:09 EDT, Boricua
no flags Details
Second messages log found (2.89 MB, text/plain)
2012-04-28 06:12 EDT, Boricua
no flags Details
Dmesg output (26.51 KB, application/octet-stream)
2012-09-10 16:06 EDT, Boricua
no flags Details
Ethtool output (25.75 KB, application/octet-stream)
2012-09-10 16:07 EDT, Boricua
no flags Details
wpa_supplicant log (32.03 KB, text/x-log)
2012-09-13 14:31 EDT, Boricua
no flags Details

  None (edit)
Description Boricua 2012-04-21 06:02:39 EDT
Description of problem:
Wireless option becomes unavailable at random, sometimes working after rebooting and others not at all.

Version-Release number of selected component (if applicable):
Fully updated.

How reproducible:
Every time I reboot.

Steps to Reproduce:
1.Log in after reboot.
2.NetworkManager either connects without issue to router for a while or at least tries to connect but fails. Other times wireless is unavailable at once.
3.Wireless is reported as unavailable.
  
Actual results:
No wireless connectivity, although wired runs without issue.

Expected results:
Full wireless connectivity at once.

Additional info:
I am using this Atheros wireless card since at least Fedora 14.  As already said, sometimes wireless works without issues for a day and then collapses. Sometimes doesn't start at all after a fresh reboot, and sometimes it starts after a reboot, detects wireless signals and then keeps trying to connect unsuccessfully to my router, asking for the password several times, before it collapses again.
Comment 1 Boricua 2012-04-22 09:25:03 EDT
I just updated NetworkManager to version 0.9.4.0-6 and, so far, the connection issue seems solved.  However, and given that I have seen before NetworkManager performing ok for a couple of days before failing, I will wait for a while and then report back.
Comment 2 Boricua 2012-04-22 09:32:37 EDT
No, it didn't took that long to start failing again. After an initially successful login to my home wireless network, half an hour later NetworkManager disconnected and started asking for the password to login again.  It's essentially the same situation.
Comment 3 Dan Winship 2012-04-27 16:05:09 EDT
Please attach /var/log/messages (and indicate at what time the connection was lost if it's not super obvious from the log)
Comment 4 Boricua 2012-04-28 06:07:58 EDT
I'm attaching two logs I found in my system. I'm no expert, but from what I saw it appears wlan went down four minutes after launching the whole system.
Comment 5 Boricua 2012-04-28 06:09:56 EDT
Created attachment 580956 [details]
Messages log
Comment 6 Boricua 2012-04-28 06:12:11 EDT
Created attachment 580957 [details]
Second messages log found
Comment 7 Dan Williams 2012-04-28 14:27:57 EDT
The logs indicate that on "Apr 17 10:46:07" a yum update performed and update of NetworkManager, which due to a bug in the packages acutally restarts NM.  That's been fixed recently as part of bug 812967.

Then at "Apr 17 10:51:17" logs indicate that the laptop's Airplane Mode (rfkill) switch was enabled, which terminated the wifi connection, or else the "Wireless Enabled" option was unchecked in the applet or GNOME shell.  The same thing is indicated at "Apr 17 15:56:31":

Apr 17 15:56:31 Hogar NetworkManager[710]: <info> (wlan0): device state change: activated -> unavailable (reason 'none') [100 20 0]
Apr 17 15:56:31 Hogar NetworkManager[710]: <info> (wlan0): deactivating device (reason 'none') [0]
Apr 17 15:56:31 Hogar NetworkManager[710]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 32547
Apr 17 15:56:31 Hogar NetworkManager[710]: <info> (wlan0): taking down device.
Apr 17 15:56:31 Hogar NetworkManager[710]: <info> WiFi hardware radio set disabled
Apr 17 15:56:31 Hogar NetworkManager[710]: <info> WiFi now disabled by radio killswitch

The killswitch might also be caused by choosing to disable wireless through the UI.  When this happens, can you grab the output of:

nmcli nm
rfkill list

Thanks!
Comment 8 Boricua 2012-04-29 06:36:30 EDT
I will try my best.  The problem is that during the last reboots of this system wireless has not being available as an option.  Is as if NM were not detecting the atheros card (in fact, my first suspicion was precisely faulty hardware, but then found out wireless became sometimes available simply by rebooting).  I also just found out kernel 3.3.4-1 became available, so I will try testing after installation.
Comment 9 collura 2012-05-30 18:49:32 EDT

from boricua second attached log: 

  https://bugzilla.redhat.com/attachment.cgi?id=580957
  >   Apr 18 21:38:21 Hogar kernel: [124719.241304] ath5k phy0: gain calibration timeout (2412MHz)

so maybe related to:

  https://bugzilla.redhat.com/show_bug.cgi?id=638943
Comment 10 Jirka Klimes 2012-09-06 06:00:26 EDT
ath5k driver is probably misbehaving.

Do you still experience issues with wireless with newest NM and kernel?
If so please attach /var/log/messages again.
Comment 11 Boricua 2012-09-06 12:09:24 EDT
(In reply to comment #10)
> ath5k driver is probably misbehaving.
> 
> Do you still experience issues with wireless with newest NM and kernel?
> If so please attach /var/log/messages again.

Yes, same situation still. NM works with wireless after rebooting with new kernel, then around one or two hours later starts loosing signal, after which it states that wireless is unavailable. Cable connection keeps working ok.
Comment 12 Jirka Klimes 2012-09-07 08:50:40 EDT
Would you please attach output of
$ dmesg
# ethtool -S wlan0

when you have the problems.
Comment 13 Boricua 2012-09-10 08:37:29 EDT
Ok. I just restarted the computer and wireless is working again for the time being. As soon as I find the issue again I will post the output requested.
Comment 14 Boricua 2012-09-10 16:06:11 EDT
After several hours of use, the problem is back. I'm attaching the outputs I just got.
Comment 15 Boricua 2012-09-10 16:06:57 EDT
Created attachment 611561 [details]
Dmesg output
Comment 16 Boricua 2012-09-10 16:07:51 EDT
Created attachment 611562 [details]
Ethtool output
Comment 17 Boricua 2012-09-10 16:12:19 EDT
Further details. As usual, NM interrupts to ask for wifi password. After providing password, NM starts with wifi again for a few seconds, then asks for password again,... and again. Wireless becomes unavailable.
Comment 18 Jirka Klimes 2012-09-11 07:44:33 EDT
As a workaround, try disabling powersaving, which could help preventing
random disconnects:
# iwconfig wlan0 power off

Also, it would help us to see detailed logs from wpa_supplicant. Here's how to get them:
https://live.gnome.org/NetworkManager/Debugging#wpa_supplicant07

Reassigning to kernel for now ...
Comment 19 Boricua 2012-09-11 07:56:24 EDT
(In reply to comment #18)
> As a workaround, try disabling powersaving, which could help preventing
> random disconnects:
> # iwconfig wlan0 power off
> 
> Also, it would help us to see detailed logs from wpa_supplicant. Here's how
> to get them:
> https://live.gnome.org/NetworkManager/Debugging#wpa_supplicant07
> 
> Reassigning to kernel for now ...

Thanks, I'll try that and report back later. Let me report first that some progress seems to have being achieved. At least NM now reports the wireless option as "available", although no signals are detected.  After several hours of use with wireless option activated, NM detects the wireless signals and tries to connect, without success.
Comment 20 Boricua 2012-09-11 08:02:36 EDT
Tried the iwconfig command, but this is what I got:

[root@Hogar ~]# iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.
[root@Hogar ~]#
Comment 21 Boricua 2012-09-13 14:31:05 EDT
Created attachment 612569 [details]
wpa_supplicant log

As requested, I ran the commands and got the following log after wireless collapse.  Hope it helps.
Comment 22 Boricua 2012-12-03 05:05:00 EST
Since moving to kernel 3.6 in Fedora 17 and now Fedora 18 alpha, I haven't notice any loss of wifi signal nor further signs of instability from Network Manager. Given that it has been like this for more than two months now, I believe it is safe to close this bug.  Of course, I leave it to you.
Comment 23 Josh Boyer 2012-12-03 07:33:17 EST
Thank you for letting us know.  If you have further troubles with atk5k, please open a new bug report with the relevant details.

Note You need to log in before you can comment on or make changes to this bug.