Bug 814986 - Missing dependencies in the package
Missing dependencies in the package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-rhc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guillermo Gómez
Fedora Extras Quality Assurance
:
: 816760 818217 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 17:23 EDT by Matěj Cepl
Modified: 2012-05-04 12:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-rhc-0.91.12-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 12:00:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2012-04-21 17:23:42 EDT
Description of problem:
When rebuilding the package from src.rpm, I get no errors on yum install and yet, rhc-chk fails to run:

wycliff:WEB-INF (master) $ rhc-chk -h
/usr/share/rubygems/rubygems/dependency.rb:247:in `to_specs': Could not find test-unit (>= 0) amongst [TicGit-ng-1.0.2.9, TicGit-ng-1.0.1, bundler-1.0.18, ditz-0.5, gash-0.1.3, git-1.2.5, gli-1.3.2, gli-1.2.5, gli-1.1.1, grancher-0.1.5, io-console-0.3, jeweler-1.6.4, json-1.5.3, json_pure-1.6.3, minitest-2.10.1, open4-1.1.0, open4-0.9.6, parseconfig-0.5.2, rainbow-1.1.1, rainbow-1.1, rake-0.9.2.2, rake-0.9.2, rdoc-3.9.4, rdoc-3.9.3, rdoc-3.9.2, rhc-0.88.9, sdoc-0.3.1, svn2git-2.1.0, svn2git-2.0.0, trac4r-1.2.4, trac4r-1.2.3, trollop-1.16.2] (Gem::LoadError)
	from /usr/share/rubygems/rubygems/dependency.rb:256:in `to_spec'
	from /usr/share/rubygems/rubygems.rb:1209:in `gem'
	from /usr/share/gems/gems/rhc-0.88.9/bin/rhc-chk:11:in `<top (required)>'
	from /usr/bin/rhc-chk:19:in `load'
	from /usr/bin/rhc-chk:19:in `<main>'


Version-Release number of selected component (if applicable):
rubygem-rhc-0.88.9-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Guillermo Gómez 2012-04-25 04:59:16 EDT
Yes, there's a missing dependency, im taking care of it, meanwhile work around it:

gem install rhc-rest

The missing dep where not listed in rhc-0.88.9.gemspec at all, it appeared at newest version 0.90.7.

Afaik, with the next release after 0.90.7, more or less in a week or two they are pulling rhc-rest back into the main rhc so we will wait and make no changes untill then since it will take longer to package rhc-rest and include it in Fedora.

Thanks for reporting
Comment 2 Guillermo Gómez 2012-04-30 11:27:48 EDT
*** Bug 816760 has been marked as a duplicate of this bug. ***
Comment 3 Troy Dawson 2012-04-30 11:44:32 EDT
The rhc 0.91.12 ruby gem  has been published.  The rhc-rest dependancy was pulled back into the gem, so it should have the same dependancies as before.
Try it again with the newer version.
Comment 4 Matěj Cepl 2012-04-30 11:56:55 EDT
(In reply to comment #3)
> The rhc 0.91.12 ruby gem  has been published.  The rhc-rest dependancy was
> pulled back into the gem, so it should have the same dependancies as before.
> Try it again with the newer version.

Is there a src.rpm package somewhere?
Comment 5 Guillermo Gómez 2012-04-30 16:56:53 EDT
http://gomix.fedorapeople.org/rubygem-rhc/rubygem-rhc-0.91.12-1.fc17.src.rpm

I will finish it as as i can.
Comment 6 Matěj Cepl 2012-04-30 17:32:51 EDT
I don't understand what's the problem, but the testing result lead to the exactly same fail as before:

wycliff:coelodonta (master) $ rpm -q rubygem-rhc
rubygem-rhc-0.91.12-1.el7.noarch
wycliff:coelodonta (master) $ gem list --local
*** LOCAL GEMS ***

bundler (1.0.18)
ditz (0.5)
gash (0.1.3)
git (1.2.5)
gli (1.3.2, 1.2.5, 1.1.1)
grancher (0.1.5)
io-console (0.3)
jeweler (1.6.4)
json (1.7.0, 1.5.3)
json_pure (1.6.3)
minitest (2.10.1)
open4 (1.1.0, 0.9.6)
parseconfig (0.5.2)
rainbow (1.1.1, 1.1)
rake (0.9.2.2, 0.9.2)
rdoc (3.9.4, 3.9.3, 3.9.2)
rhc (0.91.12)
sdoc (0.3.1)
svn2git (2.1.0, 2.0.0)
test-unit (2.4.8)
TicGit-ng (1.0.2.9, 1.0.1)
trac4r (1.2.4, 1.2.3)
trollop (1.16.2)
wycliff:coelodonta (master) $ rhc-chk -h
/usr/share/rubygems/rubygems/dependency.rb:247:in `to_specs': Could not find rest-client (>= 0) amongst [TicGit-ng-1.0.2.9, TicGit-ng-1.0.1, bundler-1.0.18, ditz-0.5, gash-0.1.3, git-1.2.5, gli-1.3.2, gli-1.2.5, gli-1.1.1, grancher-0.1.5, io-console-0.3, jeweler-1.6.4, json-1.7.0, json-1.5.3, json_pure-1.6.3, minitest-2.10.1, open4-1.1.0, open4-0.9.6, parseconfig-0.5.2, rainbow-1.1.1, rainbow-1.1, rake-0.9.2.2, rake-0.9.2, rdoc-3.9.4, rdoc-3.9.3, rdoc-3.9.2, rhc-0.91.12, sdoc-0.3.1, svn2git-2.1.0, svn2git-2.0.0, test-unit-2.4.8, trac4r-1.2.4, trac4r-1.2.3, trollop-1.16.2] (Gem::LoadError)
	from /usr/share/rubygems/rubygems/specification.rb:777:in `block in activate_dependencies'
	from /usr/share/rubygems/rubygems/specification.rb:766:in `each'
	from /usr/share/rubygems/rubygems/specification.rb:766:in `activate_dependencies'
	from /usr/share/rubygems/rubygems/specification.rb:750:in `activate'
	from /usr/share/rubygems/rubygems.rb:1232:in `gem'
	from /usr/bin/rhc-chk:22:in `<main>'
wycliff:coelodonta (master) $
Comment 7 Guillermo Gómez 2012-05-01 05:07:43 EDT
That's because is not finished, from the top of my mind, i think rubygem-rest-client is missing (new dep).
Comment 8 Guillermo Gómez 2012-05-01 11:50:59 EDT
rawhide, f14, f15, f16 updates pushed.

Please test el6 version from an scratch-build 

* http://koji.fedoraproject.org/koji/taskinfo?taskID=4040188
Comment 9 Matěj Cepl 2012-05-02 08:24:58 EDT
(In reply to comment #8)
> rawhide, f14, f15, f16 updates pushed.
> 
> Please test el6 version from an scratch-build 
> 
> * http://koji.fedoraproject.org/koji/taskinfo?taskID=4040188

How can I test it without rubygem-rest-client (which has not been packaged yet, right)?
Comment 10 Troy Dawson 2012-05-02 09:39:03 EDT
There was a typo in his requires.  rubygem-rest-client has been in all the releases for a while I believe.

http://koji.fedoraproject.org/koji/packageinfo?packageID=9969
Comment 11 Fedora Update System 2012-05-03 06:41:27 EDT
rubygem-rhc-0.91.12-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rubygem-rhc-0.91.12-2.el6
Comment 12 Troy Dawson 2012-05-03 09:03:36 EDT
*** Bug 818217 has been marked as a duplicate of this bug. ***
Comment 14 Matěj Cepl 2012-05-03 11:51:53 EDT
Is there any particular reason why you hard-code this requirement

Requires:      ruby(abi) = 1.8

I am trying to make this build on a distro where we have already ruby 1.9. With eliminating this line, it seems to work just fine:

wycliff:coelodonta (master) $ rhc-chk -l login -p secret 
/home/matej/.gem/gems/rhc-0.91.12/bin/rhc-chk:108: Use RbConfig instead of obsolete and deprecated Config.
Loaded suite /usr/bin/rhc-chk
Started
.......

Finished in 12.816356885 seconds.

7 tests, 23 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications
100% passed

0.55 tests/s, 1.79 assertions/s
wycliff:coelodonta (master) $ 

(what's that about RbConfig?)
Comment 15 Fedora Update System 2012-05-03 13:01:30 EDT
Package rubygem-rhc-0.91.12-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing rubygem-rhc-0.91.12-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5755/rubygem-rhc-0.91.12-2.el6
then log in and leave karma (feedback).
Comment 16 Adam 2012-05-03 19:16:03 EDT
Not sure if you want/need bugs against F17b Live, but following openshift install steps published on the web  (https://openshift.redhat.com/app/getting_started ) doesn't work.  I had to yum erase rhc and yum install rubygem-rhc.
Comment 17 Matěj Cepl 2012-05-04 00:51:03 EDT
(In reply to comment #16)
> Not sure if you want/need bugs against F17b Live, but following openshift
> install steps published on the web
> (https://openshift.redhat.com/app/getting_started ) doesn't work.  I had to yum
> erase rhc and yum install rubygem-rhc.

F17b Live will certainly have too old packages. Install package from above shown URL on admin.fedoraproject.org.
Comment 18 Matěj Cepl 2012-05-04 06:01:15 EDT
$ rpm -ql rubygem-rhc|grep -c $HOME
251
$ 

I am sorry, but this is completely unacceptable ... Fedora package has no business to push any files in users $HOME. Please install those files according to https://fedoraproject.org/wiki/Packaging/Ruby#Build_Architecture_and_File_Placement somewhere to %{_datadir} or something.
Comment 19 Troy Dawson 2012-05-04 11:05:41 EDT
Please do a sanity check, like "echo $HOME" or do a "rpm -ql rubygem-rhc" before posting a bug like this.

$ rpm -ql rubygem-rhc | wc -l
300
$ rpm -ql rubygem-rhc | grep -c /usr/lib/ruby/
286
$ rpm -ql rubygem-rhc | grep -c /usr/bin/
14
$ rpm -ql rubygem-rhc|grep -c $HOME
0
$

As you can see (which you would see if you didn't do the grep) there are 300 files.  286 of them are in /usr/lib/ruby, the rest are in /usr/bin

I've tested this on the EPEL6, Fedora 17, and Fedora 16, all with the same results.

I don't know where you got your rubygem-rhc, but it isn't the one from Fedora or EPEL.
Comment 20 Matěj Cepl 2012-05-04 11:14:12 EDT
(In reply to comment #19)
> I don't know where you got your rubygem-rhc, but it isn't the one from Fedora
> or EPEL.

Rebuilt of F17 -2 package, -3 works well.
Comment 21 Fedora Update System 2012-05-04 12:00:12 EDT
rubygem-rhc-0.91.12-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.