Bug 815227 - [glusterfs-3.3.0qa37] - rmdir failed when more bricks were added to the volume.
[glusterfs-3.3.0qa37] - rmdir failed when more bricks were added to the volume.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
pre-release
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: shishir gowda
:
: 795642 831940 835030 875035 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 03:37 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:49:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glusterfs client log file (15.30 KB, text/x-log)
2012-04-23 03:37 EDT, M S Vishwanath Bhat
no flags Details

  None (edit)
Description M S Vishwanath Bhat 2012-04-23 03:37:34 EDT
Created attachment 579429 [details]
glusterfs client log file

Description of problem:
I was running rm -rf of a directory tree when added 2 more bricks to a 2 node distribute volume. rm -rf failed with following error.
[root@gqac013 glusterfs]# rm -rf a/
rm: fts_read failed: No such file or directory

Actually this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=794652

Since the above bug is closed and there is no way to re-open the bug, I'm opening a new bug. 

Version-Release number of selected component (if applicable):
glusterfs-3.3.0qa37

How reproducible:
Often

Steps to Reproduce:
1. Create and start a 2 node replicated volume.
2. Create a directory tree on the mountpoint. mkdir -p `perl -e "print 'a/' x 2000"`
3. Now run 'rm -rf a/' on the mountpoint and meanwhile add 2 more bricks to the volume to make it 2*2 distributed-replicated.

  
Actual results:
sys     0m0.113s
[root@gqac013 glusterfs]# rm -rf a/
rm: fts_read failed: No such file or directory


Expected results:
rm -rf should not fail.

Additional info:

Attaching the client logs file.
Comment 1 shishir gowda 2012-05-07 02:21:31 EDT
The issue is seen when a single brick volume is converted to a distribute volume(through add-brick). Existing directories would not have any extended attributes set on them, which would lead to failure.

Removing the 3.3.0beta milestone, as this issue can not be fixed in this time frame.
Documentation updates relating to this bug is sufficient for the time being.
Comment 2 shishir gowda 2012-05-07 04:54:23 EDT
*** Bug 795642 has been marked as a duplicate of this bug. ***
Comment 3 Amar Tumballi 2012-06-02 01:31:30 EDT
http://review.gluster.com/3213 is pushed to master branch, which should fix the issue.
Comment 4 shishir gowda 2012-06-25 06:45:42 EDT
*** Bug 835030 has been marked as a duplicate of this bug. ***
Comment 5 Rajesh 2012-08-02 05:24:09 EDT
*** Bug 831940 has been marked as a duplicate of this bug. ***
Comment 6 Vijay Bellur 2012-10-25 05:09:36 EDT
CHANGE: http://review.gluster.org/3838 (glusterd-volgen: by default include 'cluster/distribute' in volfile) merged in release-3.3 by Vijay Bellur (vbellur@redhat.com)
Comment 7 Vijay Bellur 2012-11-05 19:02:51 EST
CHANGE: http://review.gluster.org/4151 (POSIX sh uses = and not ==) merged in master by Anand Avati (avati@redhat.com)
Comment 8 Vijay Bellur 2012-12-13 02:06:08 EST
CHANGE: http://review.gluster.org/4299 (NetBSD MS_RDONLY portability build fix) merged in master by Anand Avati (avati@redhat.com)
Comment 9 Vijay Bellur 2012-12-13 15:33:31 EST
CHANGE: http://review.gluster.org/4308 (Spurious reserved port warning fix) merged in master by Anand Avati (avati@redhat.com)
Comment 10 Vijay Bellur 2012-12-15 12:23:42 EST
CHANGE: http://review.gluster.org/4313 (NULL reference fix in gfid log) merged in master by Vijay Bellur (vbellur@redhat.com)
Comment 11 shishir gowda 2013-03-22 03:06:11 EDT
*** Bug 875035 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.