Bug 835030 - kernel compilation failed when new bricks were added to replicate volume
kernel compilation failed when new bricks were added to replicate volume
Status: CLOSED DUPLICATE of bug 815227
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.3-beta
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 06:18 EDT by Shwetha Panduranga
Modified: 2013-12-18 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 06:45:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glusterfs logs, history of commands executed on storage_node1/node2/node3 and fuse mount (85.61 MB, application/x-gzip)
2012-06-25 06:27 EDT, Shwetha Panduranga
no flags Details

  None (edit)
Description Shwetha Panduranga 2012-06-25 06:18:28 EDT
Description of problem:
-----------------------
Kernel compilation on fuse mount failed when new bricks were added to replicate volume (1x3) to change it to distribute-replicate volume. 


fuse-mount log output:-
---------------------
[2012-06-25 10:07:31.910374] E [afr-common.c:3664:afr_notify] 0-vol1-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
[2012-06-25 10:07:31.933711] W [fuse-resolve.c:152:fuse_resolve_gfid_cbk] 0-fuse: f68eb374-678f-47fb-9c23-093a3b6d652b: failed to resolve (Invalid argument)
[2012-06-25 10:07:31.933742] E [fuse-bridge.c:352:fuse_lookup_resume] 0-fuse: failed to resolve path (null)
[2012-06-25 10:07:31.934538] W [fuse-resolve.c:152:fuse_resolve_gfid_cbk] 0-fuse: f68eb374-678f-47fb-9c23-093a3b6d652b: failed to resolve (Invalid argument)
[2012-06-25 10:07:31.934570] E [fuse-bridge.c:352:fuse_lookup_resume] 0-fuse: failed to resolve path (null)
[2012-06-25 10:07:31.940787] W [fuse-resolve.c:152:fuse_resolve_gfid_cbk] 0-fuse: af632338-526e-4622-b380-c8a6f62cd220: failed to resolve (Invalid argument)
[2012-06-25 10:07:31.940834] W [fuse-bridge.c:2237:fuse_opendir_resume] 0-glusterfs-fuse: 1288085: OPENDIR (af632338-526e-4622-b380-c8a6f62cd220) resolution failed
[2012-06-25 10:07:32.018272] W [fuse-resolve.c:152:fuse_resolve_gfid_cbk] 0-fuse: ff14d547-357f-41d2-b3f1-2ad8035be480: failed to resolve (Invalid argument)
[2012-06-25 10:07:32.018335] E [fuse-bridge.c:1392:fuse_rmdir_resume] 0-glusterfs-fuse: RMDIR 140082544824660 (00000000-0000-0000-0000-000000000000/linux-3.4.2) resolution failed


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
3.3.0 RC2-C

How reproducible:
-----------------
often

Steps to Reproduce:
-----------------
1. Create replicate volume (1x3)
2. Create a fuse mount
3. unpack kernel tar ball on  mountpoint
4. compile it
5. perform add-brick to make it distribute-replicate volume when compilation is still in progress. 
  
Actual results:
-----------------
Kernel compilation failed

Expected results:
----------------
Compilation should not fail.
Comment 1 Shwetha Panduranga 2012-06-25 06:27:26 EDT
Created attachment 594154 [details]
glusterfs logs, history of commands executed on storage_node1/node2/node3 and  fuse mount
Comment 2 shishir gowda 2012-06-25 06:45:42 EDT
The issue is seen when a non-distribute volume is converted to a distribute
volume(through add-brick). Existing directories would not have any extended
attributes set on them, which would lead to failure.

The fix is in upstream. Marking it as a duplicate of bug 815227

*** This bug has been marked as a duplicate of bug 815227 ***

Note You need to log in before you can comment on or make changes to this bug.