Bug 815264 - Cannot place /usr on separate partition
Cannot place /usr on separate partition
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Unspecified
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 04:44 EDT by Martin Banas
Modified: 2013-01-22 11:04 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 11:04:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Banas 2012-04-23 04:44:35 EDT
Description of problem:
Hello, I cannot place /usr on separate partition, but this should be possible with /usr move feature [1].

Anaconda behaves like this since following patch was applied:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=6923f60f4cf3d3acce94fa686e97db63590238ad


Version-Release number of selected component (if applicable):
Fedora-17-Beta

How reproducible:
always

Steps to Reproduce:
1. Start installation
2. Proceed to stage2
3. Create partitioning with separate /usr
  
Actual results:
This mount point is invalid. The /usr directory must be on the / file system.

Expected results:
Anaconda should not prevent creating separate /usr partition since there's a support with "/usr move" feature:
https://fedoraproject.org/wiki/Features/UsrMove

Especially:

I have /usr as a separate partition. What changes for me?

Not sure, how you managed to do that. In general, having /usr as a separate partition does not really work right now. See http://www.freedesktop.org/wiki/Software/systemd/separate-usr-is-broken. But with this feature implemented, things will now come back to a sane and supported way of having a /usr mount point.
Comment 1 Gene Snider 2012-06-01 20:32:39 EDT
I'm having the same problem!  Hopefully, this gets fixed soon, or what's the point of the /usr move feature?

Thanks,
Gene
Comment 2 Gene Snider 2012-06-01 20:35:35 EDT
Sorry for the double post, but I forgot to mention that I have an early alpha install that's been kept updated to updates-testing's current state.  It's still fully functional and as far as I can tell, there aren't any problems associated with having /usr on a separate partition.

Gene
Comment 3 Mukundan Ragavan 2012-06-01 20:54:02 EDT
Same problem as described above. Steps to reproduce as listed in description of the bug.
Comment 4 Adam Williamson 2012-06-05 15:27:27 EDT
It was intentionally disabled because it was known to be broken:

https://bugzilla.redhat.com/show_bug.cgi?id=804913

The text on the /usr move feature page is very vague in terms of timeframe. Particularly it's not very clear what's meant by 'does not really work right now' and by 'things will now come back to a sane and supported way...'. I'm not sure you can read it as meaning that separate /usr was intended to be supported in F17; I think it's more the case that it ought to be possible in future releases with further work. But I've asked Kay for clarification.
Comment 5 Panos Kavalagios 2013-01-22 10:44:14 EST
The brand new Fedora 18 installer allows you to add /usr partition in the custom layout scheme. To my surprise, it was also able to boot the system without problems after the installation was over. We can enjoy once again having /usr in a separate filesystem.

I think the present issue can be closed as with fixed in F18 resolution.
Comment 6 Chris Lumens 2013-01-22 11:04:48 EST
Okay, thanks for re-testing.

Note You need to log in before you can comment on or make changes to this bug.