Bug 815279 - IndexError was shown on the shell command screen about UUID tests
IndexError was shown on the shell command screen about UUID tests
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 05:29 EDT by shine
Modified: 2016-11-30 19:34 EST (History)
14 users (show)

See Also:
Fixed In Version: virt-who-0.6-6.el6
Doc Type: Bug Fix
Doc Text:
Cause: virt-who can't handle all event coming from libvirtd Consequence: IndexError is written to log Fix: handle missing events too and make sure that this won't happen again when some new event will be added Result: virt-who won't show traceback when unknown event arrives
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:14:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-whoDebugInfo (132.00 KB, image/png)
2012-04-23 05:29 EDT, shine
no flags Details

  None (edit)
Description shine 2012-04-23 05:29:27 EDT
Created attachment 579462 [details]
virt-whoDebugInfo

Description of problem:
 IndexError was shown on the shell command screen about UUID tests.

 Version-Release number of selected component (if applicable):
 rhev-hypervisor6-6.2-20120416.0.el6

 How reproducible:
 100%

 Steps to Reproduce:
 1. Install rhevh on local host;
 2. Congigure network;
 3. Register to rhevm and sam; and add a guest on the rhevm
 4. Configure the virt-who.
     # vi /etc/sysconfig/virt-who
     VIRTWHO_BACKGROUND=1
     VIRTWHO_DEBUG=1
     VIRTWHO_INTERVAL=1
 5.Restart the virt-who service on terminal.
     # service virt-who restart

 7.Puase guest and check the terminal
 8.Resume guest and check the terminal

 Actual results:
 There is "IndexError" shown on the shell mode screen.[attachment virtwhobug.png]

 Expected results:
 No error was shown.

 Additional info:
Comment 2 shine 2012-04-23 05:49:53 EDT
The virt-who version is:virt-who-0.3-3.el6.noarch.
The SAM version is:SAM(sam-0412.2),katello-headpin-0.1.145-1.el6.noarch.


(In reply to comment #0)
> Created attachment 579462 [details]
> virt-whoDebugInfo
> 
> Description of problem:
>  IndexError was shown on the shell command screen about UUID tests.
> 
>  Version-Release number of selected component (if applicable):
>  rhev-hypervisor6-6.2-20120416.0.el6
> 
>  How reproducible:
>  100%
> 
>  Steps to Reproduce:
>  1. Install rhevh on local host;
>  2. Congigure network;
>  3. Register to rhevm and sam; and add a guest on the rhevm
>  4. Configure the virt-who.
>      # vi /etc/sysconfig/virt-who
>      VIRTWHO_BACKGROUND=1
>      VIRTWHO_DEBUG=1
>      VIRTWHO_INTERVAL=1
>  5.Restart the virt-who service on terminal.
>      # service virt-who restart
> 
>  7.Puase guest and check the terminal
>  8.Resume guest and check the terminal
> 
>  Actual results:
>  There is "IndexError" shown on the shell mode screen.[attachment
> virt-whoDebugInfo]
> 
>  Expected results:
>  No error was shown.
> 
>  Additional info:
Comment 4 Radek Novacek 2012-04-26 05:59:07 EDT
The exception is caused by unhandled type of libvirt event in logging output. Fix is simple: add the event type to the list of known events and add try block to prevent this bug from happening again.
Comment 5 Radek Novacek 2012-04-26 09:34:56 EDT
Fixed in virt-who-0.6-6.el6.
Comment 8 Radek Novacek 2012-05-02 02:35:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: virt-who can't handle all event coming from libvirtd

Consequence: IndexError is written to log

Fix: handle missing events too and make sure that this won't happen again when some new event will be added

Result: virt-who won't show traceback when unknown event arrives
Comment 9 Hui Wang 2012-05-23 03:21:47 EDT
Verified the issued. The result is PASS. 
Version:
virt-who-0.6-6.el6.noarch
subscription-manager-0.99.17-1.el6.x86_64
katello-headpin-0.2.6-4.el6_2.noarch
candlepin-0.6.2-1.el6_2.noarch
thumbslug-0.0.24-1.el6_2.noarch

Step:
 1. Install rhevh on local host;
 2. Congigure network;
 3. Register to rhevm and sam; and add a guest on the rhevm
 4. Configure the virt-who.
     # vi /etc/sysconfig/virt-who
     VIRTWHO_BACKGROUND=1
     VIRTWHO_DEBUG=1
     VIRTWHO_INTERVAL=1
 5.Restart the virt-who service on terminal.
     # service virt-who restart

 7.Puase guest and check the terminal
 8.Resume guest and check the terminal

Puase guest
==============================
Virtual machine found: rhel63: 99f1d371-bbb5-483c-a3e3-ff19480210a7
Sending list of uuids: ['99f1d371-bbb5-483c-a3e3-ff19480210a7']
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 3350, in _dispatchDomainEventCallbacks
  File "/usr/share/virt-who/virt.py", line 85, in changed
  File "/usr/share/virt-who/subscriptionmanager.py", line 81, in sendVirtGuests
subscriptionmanager.SubscriptionManagerError: Runtime Error Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1 at org.hibernate.jdbc.Expectations$BasicExpectation.checkBatched:85
^^^^^^^^This issue comes from candlepin, I have been filed a bug to candlepin(bug 823869 )

EVENT: Domain rhel63(6) Suspended Paused
Virtual machine found: rhel63: 99f1d371-bbb5-483c-a3e3-ff19480210a7
Sending list of uuids: ['99f1d371-bbb5-483c-a3e3-ff19480210a7']
EVENT: Domain rhel63(-1) Stopped Saved
Sending list of uuids: []
Sending list of uuids: []
EVENT: Domain rhel63(-1) Stopped Saved
Sending list of uuids: []

stop guest
=============================
Virtual machine found: rhel63: 99f1d371-bbb5-483c-a3e3-ff19480210a7
Sending list of uuids: ['99f1d371-bbb5-483c-a3e3-ff19480210a7']
EVENT: Domain rhel63(7) Shutdown Finished
Sending list of uuids: []
EVENT: Domain rhel63(7) Stopped Shutdown
Sending list of uuids: []
Comment 10 errata-xmlrpc 2012-06-20 10:14:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0900.html

Note You need to log in before you can comment on or make changes to this bug.