Bug 815295 - [whql][netkvm]NDISTest6.5, "Glitch free" subtest always failed in Windows 7 64/32 bits and windows 2008 R2
[whql][netkvm]NDISTest6.5, "Glitch free" subtest always failed in Windows 7 6...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 06:09 EDT by Min Deng
Modified: 2014-07-11 02:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Driver was failing WHQL certification on Windows 7 because it disregarded the request from OS to indicate only a certain number of packets during one DPC. Consequence: WHQL test failure. Outside of test environment - OS might fail to moderate the driver workload for RX path. Fix: Implement packet indication moderation. Result: WHQL certification for Windows 7 pass.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:38:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-04-23 06:09:16 EDT
Description of problem:
The job always failed in this guest.
Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-27
How reproducible:
Always,
Steps to Reproduce:

1.Setup whql ENV
2.submit NDISTest6.5 job 

Actual results:

The job always failed and can not be filter either by DTM


Expected results:

The job can passed

Additional info:
related info bz 808654
Comment 3 Yan Vugenfirer 2012-04-23 11:31:30 EDT
Please attach the logs, especially of the failing test (Glitch free).
Comment 4 Min Deng 2012-04-23 22:06:47 EDT
Created attachment 579733 [details]
One cpk and error logs were in attachment.
Comment 5 Min Deng 2012-04-24 03:18:58 EDT
Hi all,
Comment 6 Min Deng 2012-04-24 03:30:00 EDT
The issues was reproduced windows7 32 bits guest too.Uploaded the latest cpk and logs to the bug.Thanks.
Comment 7 Min Deng 2012-04-24 03:33:18 EDT
Created attachment 579771 [details]
Win7-Error-Log

windows 7 64/32 error log are in the attachment
Comment 8 Ronen Hod 2012-05-10 05:34:17 EDT
Postponed to 6.4, and removed the blocker flag.
We will use the Vista drivers for Win7 and 2K8R2, just like we did in the past.
Yan Fixed the bug, still testing, but it is too delicate for 6.3.
Comment 11 Yan Vugenfirer 2012-05-21 11:24:53 EDT
Fix:
http://git.engineering.redhat.com/?p=users/yvugenfi/internal-kvm-guest-drivers-windows/.git;a=commit;h=44e34181c9774dfa1a3e41dd1a7c4a3d7b75215b

Request for test:
1. Pass glitch free test
2. Test long (at least several hours) transfer scenarios (netperf and iperf).
3. Decrease "TestOnly.RXThrottle" driver parameter to 10 (from device manager -> advanced tab). Run long transfer scenarios.


Additional info:
1 Test out of 30 failed. In failed cases the test was complaining that we were requested to indicate only 10 packets and indicated more. According to driver printout we were never requested to indicate less than 100 packets. If this issue will detected in WHQL environment - let's gather the logs and approach MS.
Comment 12 Yan Vugenfirer 2012-05-21 11:40:37 EDT
During tests - test guest also as a server of iperf and netperf.
Comment 13 Yan Vugenfirer 2012-05-30 12:22:35 EDT
Another issue with this test - from time to time test fails with "divide by zero exception". This failure was present even before my recent changes. 
This is a definite bug of the test, I suspect the server’s side.
The root cause of this zero division is that no packets are sent and no packets are received in one of 3 test iterations.
The test’s intention is to send data for 1 millisecond.
It seems that all the commands are received by server but the server definitely does not send one of batches of packets.
There are 3 batches to be sent – they’re to be received with limits of 10, 100 and 1000 packets per DPC.
This can happen on any batch – exception terminates the test.
Comment 14 Min Deng 2012-06-05 23:40:58 EDT
  So far,the whql passed via driver 28 (under Win7 folder) on windows 7 32/64 and windows 2008 R2 platform.
  The rest testing is on going
Comment 16 Mike Cao 2012-08-23 22:50:27 EDT
QE run WHQL Test on virtoi-win-prewhql-29 and virtio-win-prewhql-31 ,did not this issue 

Based on above ,this issue has been fixed ald .move status to VERIFIED.
Comment 18 errata-xmlrpc 2013-02-21 05:38:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.