Bug 815328 - "-I, --image and -B, --build" options for aeolus-image delete require validation
"-I, --image and -B, --build" options for aeolus-image delete require validation
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Maros Zatko
Rehana
: Triaged
: 815337 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 07:37 EDT by Aziza Karol
Modified: 2012-12-04 10:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
User can now use -i and -b as alternatives to -I and -B.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:04:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 14:51:45 EST

  None (edit)
Description Aziza Karol 2012-04-23 07:37:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
#aeolus-image  delete -h
Usage: aeolus-image delete [command options]

Delete options:
    -I, --image ID                   delete build image and associated objects
    -B, --build ID                   delete build and associated objects


#aeolus-image delete  -i c087e30e-1431-4922-8a6d-6a9740593751
Image: c087e30e-1431-4922-8a6d-6a9740593751 Deleted Successfully

N.B. The following provider content must be manually removed

Provider          ID               
-------------     ------------     
ec2-us-east-1     ami-b4568ddd    


#aeolus-image delete -b 2fd6b97e-c85e-4544-8484-7aa1c08fbfb3
Build: 2fd6b97e-c85e-4544-8484-7aa1c08fbfb3 Deleted Successfully

N.B. The following provider content must be manually removed

Provider          ID               
-------------     ------------     
ec2-us-east-1     ami-b4568ddd     



Actual results:
delete works with -i,-b options.the actual options are -I and -B.

Expected results:
validation required for -I and -B option

Additional info:
 rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.12-1.el6_2.noarch
aeolus-conductor-0.8.12-1.el6_2.noarch
aeolus-conductor-daemons-0.8.12-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.12-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 2 Dave Johnson 2012-05-09 08:28:19 EDT
fairly certain this is a feature of the ruby opts parser
Comment 3 Maros Zatko 2012-05-09 08:58:07 EDT
*** Bug 815337 has been marked as a duplicate of this bug. ***
Comment 5 errata-xmlrpc 2012-12-04 10:04:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.