Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 815337 - Options for aeolus-image push needs validation
Summary: Options for aeolus-image push needs validation
Keywords:
Status: CLOSED DUPLICATE of bug 815328
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
Assignee: Maros Zatko
QA Contact: Rehana
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-23 12:08 UTC by Rehana
Modified: 2012-08-29 14:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-09 12:58:07 UTC


Attachments (Terms of Use)

Description Rehana 2012-04-23 12:08:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Issue the below command from Aeolus-cli

 #aeolus image push -h
Usage: aeolus-image push [command options]

Options:
    -I, --image ID                   ID of the base image, can be used in
                                     build and push commands, see examples
    -B, --build ID                   push all target images for a build, to 
                                     same providers as previously
    -t, --targetimages ID            Retrieve the target images from a build
    -A, --account NAME,NAME          name of specific provider account to use 
                                     for push
    -h, --help                       Get usage information for this command

2. aeolus image push -a rehnana_private_cloud_rhevm,mock -b 185ed89c-5cf5-408a-9428-f48389f5a7fa 
Build  Provider Image   Provider  Account   Status      
-----   ------------     -------- -----     -------------     
185ed89c-5cf5-408a-9428-f48389f5a7fa     7dda1567-adc0-4959-97e7-727ad4b190d1     rhevm-default     rehnana_private_cloud_rhevm     PUSHING     
185ed89c-5cf5-408a-9428-f48389f5a7fa     962d9709-7382-4cca-ae21-88d220ef020e     mock              mock                            PUSHING     

[root@hp-xw6400-01 ~]#  aeolus image push -a mock -i bb511d08-8d35-11e1-a1cb-0019bb497d5a
Image Provider Image Provider     Account     Status      ---------------------------     --------     -------     -------     
bb511d08-8d35-11e1-a1cb-0019bb497d5a     58bc9a06-d8c0-4e4e-9848-390ead0b2055     mock         mock        PUSHING     

  
Actual results:
Image push works with -a,-b,-i option

Expected results:
Image push is supposed to work only with -A, -B, and -I as per the help

Additional info:

rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.12-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-daemons-0.8.12-1.el6_2.noarch
aeolus-conductor-0.8.12-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.12-1.el6_2.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch

Comment 1 Maros Zatko 2012-05-09 12:58:07 UTC

*** This bug has been marked as a duplicate of bug 815328 ***


Note You need to log in before you can comment on or make changes to this bug.