Bug 815397 - regression when use systemtap probe tracepoint
regression when use systemtap probe tracepoint
Status: CLOSED DUPLICATE of bug 798676
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 10:15 EDT by langfang
Modified: 2015-03-22 20:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 22:50:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description langfang 2012-04-23 10:15:14 EDT
Description of problem:

regression when use systemtap  test tracepoint

Version-Release number of selected component (if applicable):

#uname -r
2.6.32-262.el6.x86_64
#rpm -qa |grep qemu-kvm
qemu-kvm-0.12.1.2-2.282.el6.x86_64
#rpm -qa |grep systemtap
systemtap-1.7-3.el6.x86_64

How reproducible:

100%
Steps to Reproduce:
#cat balloon_event.stp

probe qemu.kvm.balloon_event

{  printf("opaque = %p,  addr =%u ",opaque,addr);

}
1.[root@dhcp-65-153 tracing-script]# stap balloon_event.stp
parse error: expected literal string or number
        saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:814:8
     source:   next = $arg1;
                    ^
1 parse error.
WARNING: tapset '/usr/share/systemtap/tapset/qemu-kvm.stp' has errors, and will be skipped.
semantic error: probe point mismatch at position 0  (alternatives: __nfs __scheduler __signal __tcpmib __vm _linuxmib _signal _sunrpc _syscall _vfs begin begin(number) end end(number) error error(number) generic ioblock ioblock_trace ioscheduler ioscheduler_trace ipmib irq_handler kernel kprobe kprocess libvirt linuxmib module(string) nd_syscall netdev never nfs nfsd perf process process(number) process(string) procfs procfs(string) python scheduler scsi signal socket softirq stap staprun sunrpc syscall tcp tcpmib timer tty udp vfs vm workqueue): identifier 'qemu' at balloon_event.stp:1:7 while resolving probe point qemu.kvm.balloon_event
        source: probe qemu.kvm.balloon_event
                      ^
Pass 2: analysis failed.  Try again with another '--vp 01' option.


2.
3.
  
Actual results:
can not probe tracepoint

Expected results:

can be probe
Additional info:bug 720979 seem like the same problem,but fixed on virsion qemu-kvm-0.12.1.2-2.181.el6
Comment 2 langfang 2012-04-23 22:50:16 EDT

*** This bug has been marked as a duplicate of bug 798676 ***

Note You need to log in before you can comment on or make changes to this bug.