Bug 815740 - gwt-console-server.war doesn't contain some jars though it is not provided by every supported container (EWS)
gwt-console-server.war doesn't contain some jars though it is not provided b...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Build Process (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity medium
: ER7
: BRMS 5.3.0.GA
Assigned To: lcarlon
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 08:12 EDT by Petr Široký
Modified: 2012-06-24 22:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 22:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Široký 2012-04-24 08:12:09 EDT
Description of problem:
gwt-console-server.war doesn't contain some jars that are not not in every supported container (like EWS). 
Following jars are missing:
 - slf4j-api (in Guvnor install guide is stated, that slf4j should be copied to
   EWS's lib dir, so this should not be a problem)
 - logging implementation and slf4j bindings to this implementation 
   (e.g. log4j*.jar and slf4j-log4j*.jar)


Steps to Reproduce:
1. Deploy gwt-console-server.war to EWS.
2. Start EWS
3. NoClassDefFoundError will be thrown
  
The jars should be either included in lib dir of the gwt-console.war (which may not be possible) or the documentation must specify what jars (and from) should be copied to lib dir when deploying to EWS.
Comment 1 Lukáš Petrovický 2012-04-24 08:24:50 EDT
Necessary for supporting EWS, proposing as blocker.
Comment 2 Kris Verlaenen 2012-05-09 12:36:13 EDT
Will this be resolved by documenting this or by fixing this on the product side?  Or do you need support from the engineering team to modify this in the product branch / at the community side as well?  If so, could you recommend what needs to be done exactly?
Comment 3 Ryan Zhang 2012-05-10 06:36:51 EDT
The slf4j* jars and log4j jar issue is also happen to jboss-brms.war.
Adding the log jars in deployable war package would cause problem for EAP deployment since it's already exist in those container.

The way we did for jboss-brms.war is marked on documentation and shows the steps how to deploy it on EWS. 
See reference: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_BRMS_Platform/5/html-single/BRMS_Administrator_Guide/index.html#appendix-EWS-installation.

I think this issue also happens to designer.war, jbpm-human-task.war, business-central.war deployment.

Could we do the same way as we did for  jboss-brms.war?
Comment 4 Lukáš Petrovický 2012-05-10 08:15:54 EDT
(In reply to comment #3)
> Could we do the same way as we did for  jboss-brms.war?

I think we could - Lee?
Comment 5 lcarlon 2012-05-10 20:35:40 EDT
Hi Lukas,

I'm updating the instructions now. I'll post a link as soon as the updated instructions are online.

Thanks
Comment 6 lcarlon 2012-05-10 21:49:12 EDT
I've updated the EWS installation instructions and added them to the getting started guide as an appendix. It should be live on the internal doc stage within the next hour:

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_BRMS_Platform/5/html-single/BRMS_Getting_Started_Guide/index.html
Comment 7 Petr Široký 2012-05-11 10:48:23 EDT
Deploying into EWS is also documented in Administration Guide http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_BRMS_Platform/5/html/BRMS_Administrator_Guide/appendix-EWS-installation.html

Not sure what's the best place for that, but is should be definitely only on one place.
Comment 8 lcarlon 2012-05-11 23:01:27 EDT
Hi Petr,

I've moved it from the admin guide into the Getting Started Guide (sorry I should have made that clearer in my comment), however the Admin guide hasn't been updated on the stage yet. The EWS instructions in the admin guide will disappear with the next update.

Thanks
Lee
Comment 9 Ryan Zhang 2012-05-14 04:16:11 EDT
The fixed for this issue should be included in ER7. Please do verification on it.
Comment 11 Petr Široký 2012-05-22 08:15:28 EDT
The EWS intall guide has been updated. There are still some things that has to be added, but I will track them together with bug 815744, that is very similar to this one.
Comment 12 lcarlon 2012-06-24 22:58:42 EDT
Closing as status already set to verified.

Note You need to log in before you can comment on or make changes to this bug.