Bug 815754 - Reference to "ID" in aelous-image list should be changed to appropriate ID names
Reference to "ID" in aelous-image list should be changed to appropriate ID n...
Status: CLOSED DUPLICATE of bug 801514
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Angus Thomas
Rehana
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 08:54 EDT by Rehana
Modified: 2012-08-29 10:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 13:49:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-04-24 08:54:03 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.login to aelous-cli
2.aeolus-image list --images
ID   Name  Environment     OS    OS Version     Arch       Description    ------------------------------------     -----------     ------     -     
976b63d6-8dcf-11e1-bdad-00215e670bdd     RHEL_aziza                               EC2             RHEL-6     1
              x86_64     RHEL61 x86_64

Observation 1;

Here the id refers to Image id, so instead of showing just id it will be good to show as image id.
  
Observation 2;

aeolus-image list --builds 976b63d6-8dcf-11e1-bdad-00215e670bdd
ID               Image                                    
----     ------------------------------------     
02eff8ea-6264-487e-9926-762115846027     976b63d6-8dcf-11e1-bdad-00215e670bdd 

Here the id refers to build id, so instead of showing just id it will be good to show as build id.

Observation 3:
aeolus-image list --targetimages 02eff8ea-6264-487e-9926-762115846027
ID      Status       Build                                    
-------     --------     ------------------------------------     
1fd43535-805b-4116-8c3a-30e5e0bdeefe     COMPLETE     02eff8ea-6264-487e-9926-762115846027 

Here the id refers to target id, so instead of showing just id it will be good to show as target id.

Observation 4:

aeolus-image list --providerimages 1fd43535-805b-4116-8c3a-30e5e0bdeefe
ID  Target Identifier  Status   Target Image account  Provider Provider Type --     -----------------     -------------     -------------     
9beb9e2e-15ae-4274-a12e-ff5475bf7abe     ami-906ab1f9          COMPLETE     1fd43535-805b-4116-8c3a-30e5e0bdeefe     rehana_aws_accunt     ec2-us-east-1     ec2               

Here the id refers to provider image id, so instead of showing just id it will be good to show as provider image id.

Additional info:

rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.12-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-daemons-0.8.12-1.el6_2.noarch
aeolus-conductor-0.8.12-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.12-1.el6_2.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 1 Dave Johnson 2012-05-07 13:49:24 EDT

*** This bug has been marked as a duplicate of bug 801514 ***

Note You need to log in before you can comment on or make changes to this bug.