Bug 815767 - SELinux is preventing /usr/sbin/pppd from 'ioctl' accesses on the socket socket.
SELinux is preventing /usr/sbin/pppd from 'ioctl' accesses on the socket socket.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2d4893340299251863a96213ec3...
:
: 815768 815770 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 09:29 EDT by ManFree
Modified: 2012-04-25 11:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 11:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ManFree 2012-04-24 09:29:39 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-7.fc16.i686
reason:         SELinux is preventing /usr/sbin/pppd from 'ioctl' accesses on the socket socket.
time:           Tue Apr 24 21:29:26 2012

description:
:SELinux is preventing /usr/sbin/pppd from 'ioctl' accesses on the socket socket.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that pppd should be allowed ioctl access on the socket socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pppd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:pppd_t:s0
:Target Context                system_u:system_r:l2tpd_t:s0
:Target Objects                socket [ socket ]
:Source                        pppd
:Source Path                   /usr/sbin/pppd
:Port                          <Неизвестно>
:Host                          (removed)
:Source RPM Packages           ppp-2.4.5-18.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.1.0-7.fc16.i686 #1
:                              SMP Tue Nov 1 21:00:16 UTC 2011 i686 i686
:Alert Count                   1
:First Seen                    Вт. 24 апр. 2012 21:29:01
:Last Seen                     Вт. 24 апр. 2012 21:29:01
:Local ID                      c33b5a5b-d8da-4eca-a256-d713cd334a01
:
:Raw Audit Messages
:type=AVC msg=audit(1335288541.796:103): avc:  denied  { ioctl } for  pid=14496 comm="pppd" path="socket:[893943]" dev=sockfs ino=893943 scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:l2tpd_t:s0 tclass=socket
:
:
:type=SYSCALL msg=audit(1335288541.796:103): arch=i386 syscall=ioctl success=yes exit=0 a0=11 a1=80047437 a2=8db83c a3=11 items=0 ppid=14492 pid=14496 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pppd exe=/usr/sbin/pppd subj=system_u:system_r:pppd_t:s0 key=(null)
:
:Hash: pppd,pppd_t,l2tpd_t,socket,ioctl
:
:audit2allow
:
:#============= pppd_t ==============
:allow pppd_t l2tpd_t:socket ioctl;
:
:audit2allow -R
:
:#============= pppd_t ==============
:allow pppd_t l2tpd_t:socket ioctl;
:
Comment 1 Miroslav Grepl 2012-04-24 10:42:33 EDT
*** Bug 815768 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-24 10:43:07 EDT
*** Bug 815770 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-04-25 02:04:27 EDT
cat /tmp/l2tpd.log |audit2allow
WARNING: Policy would be downgraded from version 27 to 26.


#============= pppd_t ==============
#!!!! This avc is allowed in the current policy

allow pppd_t l2tpd_t:socket ioctl;
Comment 4 Miroslav Grepl 2012-04-25 02:07:00 EDT
Fixed in selinux-policy-3.10.0-87.fc16
Comment 5 ManFree 2012-04-25 11:24:45 EDT
No problem in selinux-policy-3.10.0-87.fc16.
Fixed.

Note You need to log in before you can comment on or make changes to this bug.