Bug 815784 - "Total" should be replaced with "Cloud quota" or something more intuitive under Clouds Page
"Total" should be replaced with "Cloud quota" or something more intuitive und...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jiri Tomasek
Rehana
: Triaged, ZStream
Depends On:
Blocks: 826137
  Show dependency treegraph
 
Reported: 2012-04-24 09:53 EDT by Shveta
Modified: 2012-12-04 10:05 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The total quota for a cloud automatically calculated to 100 per cent. The quota actually used for the particular Cloud Resource Zone differed from the actual total. This fix adds an additional column 'Cloud Quota Used'. The total quota and quota actually used now correlate.
Story Points: ---
Clone Of:
: 826137 (view as bug list)
Environment:
Last Closed: 2012-12-04 10:05:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cloud quota (212.69 KB, image/png)
2012-04-24 09:53 EDT, Shveta
no flags Details
Cloud Quota Used added (106.85 KB, image/png)
2012-09-20 16:54 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Shveta 2012-04-24 09:53:23 EDT
Created attachment 579864 [details]
cloud quota

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Created a cloud with quota 3
2. Created a cloud resource zone with quota unlimited
3. launched 3 instances
4. As shown in the attached screenshot , CRZ shows 0% and Total shows 100 %
looks really confusing 
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.9-1.el6.noarch
aeolus-conductor-0.8.9-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.9-1.el6.noarch
aeolus-configure-2.5.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-daemons-0.8.9-1.el6.noarch
Comment 1 Jiri Tomasek 2012-05-24 10:50:08 EDT
separate patch sent for 1.0.1 branch to deltacloud-internal
patch for master sent https://fedorahosted.org/pipermail/aeolus-devel/2012-May/010538.html
Comment 2 Tzu-Mainn Chen 2012-05-29 12:51:56 EDT
master patch:

3a146ec02607a850882b5457484ae43935334908
BZ815784 added Pool Family Quota Used column to Pool Families table


1.0.1 patch:

d8e59330b07b317e20e2a6d4219fbc6ffdaea78a
BZ815784 added Pool Family Quota Used column to Pool Families table
Comment 4 Ronelle Landy 2012-09-20 16:53:41 EDT
Tested rpms:

>>  rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

See attached screenshot where a default cloud with a 20 instance limit exists and a CRZ with infinite instance limit has been added. 20 running instances have been launched to the CRZ.

Marking this BZ as verified because the additional column has been added: Cloud Quota Used  - which addresses the confusion.
Comment 5 Ronelle Landy 2012-09-20 16:54:15 EDT
Created attachment 615121 [details]
Cloud Quota Used added
Comment 7 errata-xmlrpc 2012-12-04 10:05:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.