Bug 816036 - Error while uploading sources
Error while uploading sources
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse-fedorapackager (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
: 814559 819200 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 02:34 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 02:20:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-04-25 02:34:12 EDT
What steps will reproduce the problem?
1. 
2. 
3. 


-- Error Details --
Date: Wed Apr 25 08:32:25 CEST 2012
Message: An internal error occurred during: "Uploading Sources".
Severity: Error
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.core.jobs
Session Data:
eclipse.buildId=I20120417-1000
java.version=1.7.0_b147-icedtea
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

Exception Stack Trace:
java.lang.LinkageError: loader constraint violation: when resolving method "org.apache.http.impl.client.DefaultHttpClient.<init>(Lorg/apache/http/params/HttpParams;)V" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/fedoraproject/eclipse/packager/api/UploadSourceCommand, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, org/apache/http/impl/client/DefaultHttpClient, have different Class objects for the type /http/params/HttpParams;)V used in the signature
	at org.fedoraproject.eclipse.packager.api.UploadSourceCommand.getClient(UploadSourceCommand.java:414)
	at org.fedoraproject.eclipse.packager.api.UploadSourceCommand.checkSourceAvailable(UploadSourceCommand.java:226)
	at org.fedoraproject.eclipse.packager.api.UploadSourceCommand.call(UploadSourceCommand.java:193)
	at org.fedoraproject.eclipse.packager.internal.handlers.UploadHandler$1.run(UploadHandler.java:152)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Comment 1 Severin Gehwolf 2012-04-25 09:12:22 EDT
Chris, which version of httpcomponents* are you using?

$ rpm -qa | grep httpcomponents

Thanks!
Comment 2 Krzysztof Daniel 2012-04-25 10:02:07 EDT
httpcomponents-project-4.1.1-4.fc17.noarch
httpcomponents-core-4.1.4-1.fc18.noarch
httpcomponents-client-4.1.3-2.fc17.noarch
Comment 3 Severin Gehwolf 2012-05-05 12:53:19 EDT
Could it be that this is caused by the fact that httpcompontents* packages do not export * any longer? I could see that o.a.http.imp.client.DefaultHttpClient is not exported anymore. Not sure, though. Perhaps a rebuild of eclipse-fedorapackager fixes this.
Comment 4 Krzysztof Daniel 2012-05-08 02:20:33 EDT
works for me with 0.20 eclipse build (and probably other updated libraries).
Comment 5 Krzysztof Daniel 2012-05-08 02:23:03 EDT
*** Bug 819200 has been marked as a duplicate of this bug. ***
Comment 6 Krzysztof Daniel 2012-05-08 02:24:53 EDT
*** Bug 814559 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.