Bug 816057 - [as7] Describe jndi-name + connector handling for HornetQ children
[as7] Describe jndi-name + connector handling for HornetQ children
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
4.3
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: JON 3.1.0
Assigned To: Deon Ballard
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-04-25 03:28 EDT by Heiko W. Rupp
Modified: 2016-02-24 12:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 12:40:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2012-04-25 03:28:57 EDT
HornetQ children JMS Queue, JMS Topic, Connection Factory) all have a list box to pass jndi names.
Due to Bug 815305 , the UI can not enforce that at least 1 jndi name is given, so that the user can
actually pass 0 entries without being warned. 
This condition is caught after submit and the create resource request will fail.
Same applies to configuration update



For connection factories, there is a connector element with two properties
- name   -- required
- backup  -- optional

The name is required. For whatever reasons, the UI can not enforce that this is needed on child resource creation. The presence of the name is enforced at plugin level. If no name is given creation will fail with an appropriate error message.
For configuration updates, this is no issue.
Comment 1 Heiko W. Rupp 2012-04-25 08:04:20 EDT
See also 816169 wrt connection factories
Comment 2 Heiko W. Rupp 2012-05-02 08:24:46 EDT
This has now changed slightly for connection-factories:

"backup" for the connector is no longer shown in the UI.
As the UI can not enforce that exactly one of connector and discovery-group-name are present, the plugin enforces this and reports appropriate errors.
Comment 3 Deon Ballard 2012-09-12 09:40:18 EDT
I added this to the release notes here (fourth in the list):
https://access.redhat.com/knowledge/docs/en-US/JBoss_Operations_Network/3.1/html/3.1_Release_Notes/Known-Issues-with-this-release.html#known-issues-eap6

Since that issue is going to be fixed quickly, I didn't add it to the EAP 6 config documentation.
Comment 4 Armine Hovsepyan 2012-09-12 12:42:46 EDT
as talked to Deon, marking this back to on_dev to add info into regular docs.

Note You need to log in before you can comment on or make changes to this bug.