Bug 816164 - nslookup exits with zero return value when DNS server is not accessible
Summary: nslookup exits with zero return value when DNS server is not accessible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind
Version: 6.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 756608 760559 829243 829829
TreeView+ depends on / blocked
 
Reported: 2012-04-25 11:48 UTC by Jan Stodola
Modified: 2012-07-27 14:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 816166 829243 829829 (view as bug list)
Environment:
Last Closed: 2012-06-20 13:41:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0830 normal SHIPPED_LIVE bind bug fix and enhancement update 2012-06-19 20:49:20 UTC

Description Jan Stodola 2012-04-25 11:48:39 UTC
Description of problem:
nslookup exits with zero return value even when a query fails (DNS server doesn't respond): 

[root@rtt5 ~]# rpm -qf `which nslookup`
bind-utils-9.8.2-0.7.rc1.el6.s390x
[root@rtt5 ~]# nslookup 11.22.33.44 172.16.1.1
;; connection timed out; trying next origin
;; connection timed out; trying next origin
;; connection timed out; trying next origin
;; connection timed out; no servers could be reached

[root@rtt5 ~]# echo $?
0

Compare with the "host" command:
[root@rtt5 ~]# host 11.22.33.44 172.16.1.1
;; connection timed out; no servers could be reached
[root@rtt5 ~]# echo $?
1

Version-Release number of selected component (if applicable):
bind-utils-9.8.2-0.7.rc1.el6

How reproducible:
always

Steps to Reproduce:
1. nslookup 11.22.33.44 172.16.1.1
2. echo $?
  
Actual results:
0

Expected results:
non-zero value

Additional info:
This bug blocks verification of bug 756608, proposing as a blocker.

Comment 7 errata-xmlrpc 2012-06-20 13:41:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0830.html


Note You need to log in before you can comment on or make changes to this bug.