This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 816324 - virt-manager qemu+ssh connects with wrong user
virt-manager qemu+ssh connects with wrong user
Status: CLOSED DUPLICATE of bug 811397
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 15:38 EDT by Bryan Hughes
Modified: 2012-04-26 16:33 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:33:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Hughes 2012-04-25 15:38:42 EDT
Description of problem:
After updating to libvirt 0.9.11 the remote ssh connection  is no longer honoring username specifications.  I see this in both virt-manager and virsh

I have GSSAPI passwordless login ssh to root setup on tccvm0,  after the update I get this:
virsh -c qemu+ssh://root@tccvm0/system
khan@tccvm0's password:


Version-Release number of selected component (if applicable):
libvirt-client-0.9.11-1.fc17.x86_64

How reproducible:
Everytime in virsh and virt-manager

Steps to Reproduce:
1. Log into machine as normal user
2. 
3.
  
Actual results:
virsh -c qemu+ssh://root@tccvm0/system
khan@tccvm0's password:

Expected results:
virsh -c qemu+ssh://root@tccvm0/system
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh #


Additional info:
This seems to have been seen and fixed in debian:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667636
Comment 1 Dave Allan 2012-04-25 16:33:51 EDT
Cole, this has been fixed upstream, hasn't it?
Comment 2 Laine Stump 2012-04-25 19:40:04 EDT
Yes, It's fixed in the following upstream commit. I'm moving it to POST so that commit can be cherry-picked for the next build for F17:

commit 4eb1c2560d1ab8bae620788d343e9e7b32ddc066
Author: Guido Günther <agx@sigxcpu.org>
Date:   Thu Apr 5 17:52:42 2012 +0200

    virURIParse: don't forget to copy the user part
    
    This got dropped with 300e60e15b22387dda41ed5985a9ebadfd86dd25
Comment 3 Cole Robinson 2012-04-26 10:09:14 EDT
Yeah I'll be doing a build today
Comment 4 Cole Robinson 2012-04-26 16:33:13 EDT

*** This bug has been marked as a duplicate of bug 811397 ***

Note You need to log in before you can comment on or make changes to this bug.