Bug 816468 - wrong message display in virt-viewer when reconnect guest for multiple monitors testing.
wrong message display in virt-viewer when reconnect guest for multiple monito...
Status: CLOSED DUPLICATE of bug 816550
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 03:31 EDT by zhe peng
Modified: 2012-05-04 11:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 11:42:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhe peng 2012-04-26 03:31:08 EDT
Description of problem:
wrong message display in virt-viewer when use --reconnect --wait for multiple monitors testing.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64
libvirt-0.9.10-14.el6.x86_64
qemu-kvm-0.12.1.2-2.267.el6.x86_64
spice-gtk-0.11-8.el6.x86_64
spice-server-0.10.1-5.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1: prepare win guest with spice
2: add two qxl video,and start the guest
3: in guest , install qxl-win driver,config two monitors
4: use virt-viewer to open guest with --reconnect --wait
 #virt-viewer win7_64 --reconnect --wait
5: virt-viewer will open two display
6: in host console shutdown the guest,run
#virsh destroy win7_64
  
Actual results:
the first virt-viewer window show message "Waiting for guest domain to re-start"
the second window show message "Connected to graphic server", this is not make sense


Expected results:
all virt-viewer message should same with first window
"Waiting for guest domain to re-start"

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 00:43:08 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Daniel Berrange 2012-05-04 11:42:41 EDT
The windows should not even have remained visible once the guest shutdown. This is actually the same root cause as bug 816550

*** This bug has been marked as a duplicate of bug 816550 ***

Note You need to log in before you can comment on or make changes to this bug.