Bug 816550 - virt-viewer create new window for multiple monitors when reconnect to a guest.
virt-viewer create new window for multiple monitors when reconnect to a guest.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
: 816468 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 07:26 EDT by zhe peng
Modified: 2012-06-20 08:12 EDT (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:12:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhe peng 2012-04-26 07:26:35 EDT
Description of problem:
virt-viewer create new window for multiple monitors when reconnect to a guest.


Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64
libvirt-0.9.10-14.el6.x86_64
qemu-kvm-0.12.1.2-2.267.el6.x86_64
spice-gtk-0.11-8.el6.x86_64
spice-server-0.10.1-5.el6.x86_64
qxl-win-0.1-14

How reproducible:
always

Steps to Reproduce:
1: prepare win guest with spice
2: add two qxl video,and start the guest
3: in guest , install qxl-win driver,config two monitors
4: use virt-viewer to open guest with --reconnect --wait
 #virt-viewer win7_64 --reconnect --wait
5: virt-viewer will open two display
6: in host console,use virsh restart the guest,run
 #virsh destroy win7_64
 #virsh start win7_64

Actual results:
when windows guest complete started,virt-viewer will create a new window to show second monitor,the old one still exist and without anything.
there have three virt-viewer display. 

Expected results:
should only have two virt-viewer page when guest have two monitor.

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 01:00:40 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Daniel Berrange 2012-05-04 11:42:41 EDT
*** Bug 816468 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Berrange 2012-05-04 11:43:37 EDT
The problem was that we discarded the VirtViewerWindow object when the guest shutdown, but we forgot to destroy the GtkWindow, so the windows on screen stayed visible.

https://www.redhat.com/archives/virt-tools-list/2012-May/msg00007.html
Comment 7 Geyang Kong 2012-05-07 03:21:57 EDT
Reproduced on the following build:
virt-viewer-0.5.2-6.el6.x86_64

Verified pass on the following build:
virt-viewer-0.5.2-7.el6.x86_64

Steps:
Same as description

Actual result:
1. After guest shut down, there is only single window left.
2. After restarting guest, the second window will be displayed.

So change this bug to verified.
Comment 9 errata-xmlrpc 2012-06-20 08:12:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html

Note You need to log in before you can comment on or make changes to this bug.