Bug 81674 - IMAP MH folders not accessible anymore
IMAP MH folders not accessible anymore
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
: MoveUpstream
: 82091 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-12 12:02 EST by Jos Vos
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 19:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Evolution session log 1.0.8 (2.05 KB, text/plain)
2003-01-12 14:53 EST, Jos Vos
no flags Details
Evolution session log 1.2.1 (1.74 KB, text/plain)
2003-01-12 14:53 EST, Jos Vos
no flags Details

  None (edit)
Description Jos Vos 2003-01-12 12:02:36 EST
Description of problem:
I can't access remote MH folders via IMAP anymore (worked fine in 1.0.8).

Version-Release number of selected component (if applicable):
1.2.1-2

How reproducible:
Make a new Evolution account, choose IMAP, in receiving options unselect "show
only subscribed folders" and select "override server-supplied folder namespace"
and type "#mh/" as namespace.  Remote MH folders are shown correctly in 1.0.8,
but not in 1.2.1.
Comment 1 Jeremy Katz 2003-01-12 12:50:00 EST
Could you run `CAMEL_VERBOSE_DEBUG=1 evolution-mail` and then start evolution
once it says evolution-mail is ready.  If you look there, is there anything
obviously wrong that you can see?
Comment 2 Jos Vos 2003-01-12 13:09:21 EST
I have not a good idea how I should read this, but this is the part of the log
that might be interesting:

sending : A00002 LIST #mh/ ""
received: * LIST (\NoSelect) "/" #mh/
received: A00002 OK LIST completed
sending : A00003 LIST "" #mh
received: A00003 OK LIST completed

The \NoSelect wonders me...

I also gort tons of Bonobo errors:

Bonobo-WARNING **: Serious exception on node_set '$invalid path to XML user
interface element' of '0' to '/commands/MailNextThread#sensitive'

Full log available on request.
Comment 3 Jos Vos 2003-01-12 13:29:13 EST
More info:

Evolution 1.0.8
---------------
sending : A00002 LIST "#mh/" ""
received: * LIST (\NoSelect) "/" #mh/
received: A00002 OK LIST completed
sending : A00003 LIST "" "#mh/"
received: A00003 OK LIST completed
sending : A00004 LIST "" "#mh/*"
received: * LIST () "/" #mh/folder1
received: * LIST () "/" #mh/folder2
received: * LIST () "/" #mh/inbox
received: A00004 OK LIST completed

Evolution 1.2.1
---------------
sending : A00002 LIST #mh/ ""
received: * LIST (\NoSelect) "/" #mh/
received: A00002 OK LIST completed
sending : A00003 LIST "" #mh
received: A00003 OK LIST completed
sending : A00004 LIST "" INBOX
received: * LIST (\NoInferiors) NIL INBOX
received: A00004 OK LIST completed
sending : A00005 STATUS INBOX (UNSEEN)
received: * STATUS INBOX (UNSEEN 0)
received: A00005 OK STATUS completed

Note the different A00003 lines (with/without the "/")!
Comment 4 Jeremy Katz 2003-01-12 14:29:46 EST
That doesn't actually strike me as a problem.  Can you attach the full log
(preferably for both 1.0.8 and 1.2.1)?
Comment 5 Jos Vos 2003-01-12 14:53:15 EST
Created attachment 89323 [details]
Evolution session log 1.0.8
Comment 6 Jos Vos 2003-01-12 14:53:51 EST
Created attachment 89324 [details]
Evolution session log 1.2.1
Comment 7 Jeremy Katz 2003-01-12 15:03:20 EST
This is upstream as http://bugzilla.ximian.com/show_bug.cgi?id=31745
Comment 8 Jos Vos 2003-01-12 15:08:36 EST
Seems to be a different one: there MH folders are listed, in my case the MH
folders are not listed at all.
Comment 9 Jos Vos 2003-01-12 15:25:39 EST
I've just created a new bug at Ximian myself:
http://bugzilla.ximian.com/show_bug.cgi?id=36625
Comment 10 Henrik Nordstrom 2003-01-17 08:11:18 EST
I think I am experiencing a problem very much related to this.

I have one IMAP server where I need to override the server namespace, and when
using evolution-1.2.1-2 the names shown in the folder list seems to be based on
when not having the override.

In Evolution from RedHat 8.0 folder names were "cleaned up" when using namespace
overrides to only show the names relative to the overridden namespace.
Comment 11 Jeremy Katz 2003-01-17 11:04:26 EST
*** Bug 82091 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2003-07-28 19:19:27 EDT
Watching 

Note You need to log in before you can comment on or make changes to this bug.