Bug 816843 - [WebTran] Next and Previous Fuzzy/Untranslated keyboard short cut does not work
[WebTran] Next and Previous Fuzzy/Untranslated keyboard short cut does not work
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity medium
: ---
: 1.6-beta-1
Assigned To: Patrick Huang
Joyce Chang
:
: 817563 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 03:30 EDT by Ding-Yi Chen
Modified: 2013-03-03 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version: Zanata version 1.6.0-alpha-3-SNAPSHOT (20120515-0020).
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-04-27 03:30:40 EDT
Keyboard short cut for "Next Fuzzy/Untranslated" (alt-PgDn) and "Previous Fuzzy/Untranslated" (alt-PgUp) work as if what we press is "Next Entry" or "Previous Entry"

Version-Release number of selected component (if applicable):
Zanata version 1.6.0-alpha-1 (20120419-0011).

How reproducible:
Always

Steps to Reproduce:
1. Find a document that is multiple-paged contains empty, fuzzy, and approved
translation
   Or find a related empty document, with 
   1, 2 and last entries are approved
   3, 5 entries are fuzzy
   the rest are empty.
2. Uncheck all the Message Filters (or Check all the Message Filters)
3. Click on the entry that below an Approved entry
4. Press Alt-PgUp (Keyboard shortcut of Previous Fuzzy/Untranslated"
  
Actual results:
Cursor move to Approved 

Expected results:
Cursor either move to previous Fuzzy/Untranslated entry, or stay at the current entry if no previous Fuzzy/Untranslated entry

Additional info:
"Next Fuzzy/Untranslated" and "Previous Fuzzy/Untranslated" buttons on the top works
Comment 1 Joyce Chang 2012-05-07 22:18:30 EDT
*** Bug 817563 has been marked as a duplicate of this bug. ***
Comment 3 Patrick Huang 2012-05-09 00:46:21 EDT
committed in master:
https://github.com/zanata/zanata/commit/3023cd70fd051c4f37d2fd8f9430ac2143537580
Comment 4 Patrick Huang 2012-05-10 18:32:01 EDT
committed again in master:
https://github.com/zanata/zanata/commit/f1692d24651ee0575f32c0e30ee6abddf0f19b51
Comment 5 Patrick Huang 2012-05-13 20:04:51 EDT
committed again in master:
https://github.com/zanata/zanata/commit/1a9846a12ca5f4ebd9a49894afcd41e5e8aa2587
Comment 6 Joyce Chang 2012-05-14 19:57:36 EDT
verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120515-0020).
Comment 7 Patrick Huang 2012-06-05 20:31:19 EDT
This bug was introduced during 1.6 development and is fixed before release.

Note You need to log in before you can comment on or make changes to this bug.