Bug 817001 - SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /tmp.
SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the director...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ea98d1569a642bb415e5f4f5178...
:
: 817000 817004 817005 817006 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 08:20 EDT by John L Magee
Modified: 2012-06-27 23:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:26:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John L Magee 2012-04-27 08:20:48 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.2-6.fc16.x86_64
reason:         SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /tmp.
time:           Fri 27 Apr 2012 08:20:36 AM EDT

description:
:SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /tmp.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed read access on the tmp directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rhsmcertd-worke /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rhsmcertd_t:s0
:Target Context                system_u:object_r:tmp_t:s0
:Target Objects                /tmp [ dir ]
:Source                        rhsmcertd-worke
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-1.fc16.x86_64
:Target RPM Packages           filesystem-2.4.44-1.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-6.fc16.x86_64
:                              #1 SMP Sat Apr 21 12:43:20 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Fri 27 Apr 2012 08:15:30 AM EDT
:Last Seen                     Fri 27 Apr 2012 08:15:30 AM EDT
:Local ID                      4504658e-5f9d-4f5a-99cc-72aa8c3ea395
:
:Raw Audit Messages
:type=AVC msg=audit(1335528930.845:81): avc:  denied  { read } for  pid=2170 comm="rhsmcertd-worke" name="/" dev="tmpfs" ino=16503 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:tmp_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1335528930.845:81): arch=x86_64 syscall=open success=yes exit=ENOMEM a0=7fd64308c2be a1=0 a2=1b6 a3=238 items=0 ppid=2079 pid=2170 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rhsmcertd-worke exe=/usr/bin/python2.7 subj=system_u:system_r:rhsmcertd_t:s0 key=(null)
:
:Hash: rhsmcertd-worke,rhsmcertd_t,tmp_t,dir,read
:
:audit2allow
:
:#============= rhsmcertd_t ==============
:allow rhsmcertd_t tmp_t:dir read;
:
:audit2allow -R
:
:#============= rhsmcertd_t ==============
:allow rhsmcertd_t tmp_t:dir read;
:
Comment 1 Miroslav Grepl 2012-04-27 09:24:00 EDT
*** Bug 817000 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-27 09:24:20 EDT
*** Bug 817004 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-04-27 09:24:31 EDT
*** Bug 817005 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-04-27 09:24:41 EDT
*** Bug 817006 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2012-04-27 09:26:48 EDT
I am backporting fixes from RHEL6 to Fedora.

Fixed in selinux-policy-3.10.0-88.fc16
Comment 6 Fedora Update System 2012-06-15 06:30:12 EDT
selinux-policy-3.10.0-89.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-89.fc16
Comment 7 Fedora Update System 2012-06-15 19:51:44 EDT
Package selinux-policy-3.10.0-89.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-89.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9507/selinux-policy-3.10.0-89.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-06-27 23:26:04 EDT
selinux-policy-3.10.0-89.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.