Bug 817006 - SELinux is preventing /usr/bin/rhsmcertd from 'getattr' accesses on the file /run/rhsm/update.
SELinux is preventing /usr/bin/rhsmcertd from 'getattr' accesses on the file ...
Status: CLOSED DUPLICATE of bug 817001
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-27 08:22 EDT by John L Magee
Modified: 2012-04-27 09:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-04-27 09:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John L Magee 2012-04-27 08:22:40 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.2-6.fc16.x86_64
reason:         SELinux is preventing /usr/bin/rhsmcertd from 'getattr' accesses on the file /run/rhsm/update.
time:           Fri 27 Apr 2012 08:22:30 AM EDT

:SELinux is preventing /usr/bin/rhsmcertd from 'getattr' accesses on the file /run/rhsm/update.
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:If you want to fix the label. 
:/run/rhsm/update default label should be rhsmcertd_var_run_t.
:Then you can run restorecon.
:# /sbin/restorecon -v /run/rhsm/update
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:If you believe that rhsmcertd should be allowed getattr access on the update file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep rhsmcertd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:rhsmcertd_t:s0
:Target Context                system_u:object_r:var_run_t:s0
:Target Objects                /run/rhsm/update [ file ]
:Source                        rhsmcertd
:Source Path                   /usr/bin/rhsmcertd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           subscription-manager-0.99.13-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-6.fc16.x86_64
:                              #1 SMP Sat Apr 21 12:43:20 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 27 Apr 2012 08:15:30 AM EDT
:Last Seen                     Fri 27 Apr 2012 08:15:30 AM EDT
:Local ID                      21186466-d3e0-4a4e-8a0e-eea8c537e17d
:Raw Audit Messages
:type=AVC msg=audit(1335528930.912:85): avc:  denied  { getattr } for  pid=2079 comm="rhsmcertd" path="/run/rhsm/update" dev="tmpfs" ino=27898 scontext=system_u:system_r:rhsmcertd_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=file
:type=SYSCALL msg=audit(1335528930.912:85): arch=x86_64 syscall=fstat success=yes exit=0 a0=5 a1=7fff5792ba20 a2=7fff5792ba20 a3=238 items=0 ppid=1 pid=2079 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rhsmcertd exe=/usr/bin/rhsmcertd subj=system_u:system_r:rhsmcertd_t:s0 key=(null)
:Hash: rhsmcertd,rhsmcertd_t,var_run_t,file,getattr
:#============= rhsmcertd_t ==============
:allow rhsmcertd_t var_run_t:file getattr;
:audit2allow -R
:#============= rhsmcertd_t ==============
:allow rhsmcertd_t var_run_t:file getattr;
Comment 1 Miroslav Grepl 2012-04-27 09:24:41 EDT

*** This bug has been marked as a duplicate of bug 817001 ***

Note You need to log in before you can comment on or make changes to this bug.