Bug 817182 - Systemd takes ages to reboot/poweroff if a manual PPPoE network interface is up and running
Systemd takes ages to reboot/poweroff if a manual PPPoE network interface is ...
Status: CLOSED DUPLICATE of bug 816842
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 19:05 EDT by Artem S. Tashkinov
Modified: 2012-05-04 07:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 07:11:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem S. Tashkinov 2012-04-27 19:05:17 EDT
Description of problem: Systemd takes ages to reboot if PPPoE manual networking interface is up


Version-Release number of selected component (if applicable): systemd-44-7.fc17


How reproducible: always


Steps to Reproduce:
1. ifup ppp0
2. reboot
3.
  
Actual results: 2-3 minutes pause before reboot/poweroff


Expected results: immediate reboot/poweroff


Additional info:

cat ifcfg-ppp0

USERCTL=yes
BOOTPROTO=dialup
NAME=DSLppp0
DEVICE=ppp0
TYPE=xDSL
ONBOOT=yes
PIDFILE=/var/run/pppoe-adsl.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=60
DEFROUTE=yes
SYNCHRONOUS=no
ETH=em1
PROVIDER=DSLppp0
USER=username
PEERDNS=no
DEMAND=no
VERBOUS=yes
LINUX_PLUGIN=rp-pppoe.so
Comment 1 antonio montagnani 2012-04-29 02:10:27 EDT
same if wireless has to be started by hand - at it happens now see:

https://bugzilla.redhat.com/show_bug.cgi?id=816784

When I shut down wireless by hand before shutdown, it works as expected.

I think the two bugs are strictly connected
Comment 2 antonio montagnani 2012-05-04 01:27:10 EDT
upgraded systemd this just now to systemd-44-8.fc17.i686 and it seems fine shut-down and reboot are a breeze
Comment 3 Michal Schmidt 2012-05-04 07:11:25 EDT

*** This bug has been marked as a duplicate of bug 816842 ***

Note You need to log in before you can comment on or make changes to this bug.