Bug 817206 - Size of virt-viewer/remote-viewer windows is very small after disable and enable Automatically resize.
Size of virt-viewer/remote-viewer windows is very small after disable and ena...
Status: CLOSED DUPLICATE of bug 856610
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 23:07 EDT by yuping zhang
Modified: 2013-05-08 10:16 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 10:16:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer windows (287.16 KB, image/png)
2012-04-27 23:07 EDT, yuping zhang
no flags Details

  None (edit)
Description yuping zhang 2012-04-27 23:07:44 EDT
Created attachment 580915 [details]
virt-viewer windows

Description of problem:
As default,the Automatically resize is checked.But after clear it and then checked it again,the virt-viewer/remote-viewer will become very small

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64
libvirt-0.9.10-14.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.Connect a guest with virt-viewer #virt-viewer test
2.Click View -> Automatically resize,the Automatically resize is disable.
3.Click View->Automatically resize again.

Actual results:
The windows will become very small,and can see anything in it.
See attached picture

Expected results:
The size of window should be as same as the first open it.

Additional info:
For vnc and spice,both have this problem.
Debug info:

** (virt-viewer:5794): DEBUG: fullscreen display 0: 0
** (virt-viewer:5794): DEBUG: fullscreen display 0: 0
** (virt-viewer:5794): DEBUG: Opening connection to libvirt with URI <null>

** (virt-viewer:5794): DEBUG: Add handle 7 1 0x26013d0
** (virt-viewer:5794): DEBUG: Add timeout 0x2600e70 -1 0x3d15f1a030 0x2601220 1
** (virt-viewer:5794): DEBUG: notebook show status 0x2598190
** (virt-viewer:5794): DEBUG: notebook show status 0x2598190
** (virt-viewer:5794): DEBUG: Guest 17 is running, determining display

** (virt-viewer:5794): DEBUG: Set connect info: (null),(null),(null),-1,(null),(null),(null),0
** (virt-viewer:5794): DEBUG: Guest 17 has a vnc display

** (virt-viewer:5794): DEBUG: Guest graphics listen '' is NULL or a wildcard, replacing with 'localhost'
** (virt-viewer:5794): DEBUG: Set connect info: localhost,localhost,5900,-1,(null),(null),(null),0
** (virt-viewer:5794): DEBUG: Error operation virDomainOpenGraphics forbidden for read only access
** (virt-viewer:5794): DEBUG: After open connection callback fd=-1
** (virt-viewer:5794): DEBUG: Opening direct TCP connection to display at localhost:5900:-1

** (virt-viewer:5794): DEBUG: notebook show status 0x2598190
** (virt-viewer:5794): DEBUG: Add timeout 0x2611470 -1 0x3d15e95390 0x26009e0 2
** (virt-viewer:5794): DEBUG: notebook show status 0x2598190
** (virt-viewer:5794): DEBUG: notebook show display 0x2598190
** (virt-viewer:5794): DEBUG: Display size request 100x100 (desktop 100x100)
** (virt-viewer:5794): DEBUG: Allocated 400x375
** (virt-viewer:5794): DEBUG: Child allocate 375x375
** (virt-viewer:5794): DEBUG: Display size request 50x50 (desktop 100x100)
** (virt-viewer:5794): DEBUG: Allocated 400x375
** (virt-viewer:5794): DEBUG: Child allocate 375x375
** (virt-viewer:5794): DEBUG: desktop resize 1024x768
** (virt-viewer:5794): DEBUG: Preparing main window resize
** (virt-viewer:5794): DEBUG: Decided todo 1024x768 (desktop is 1024x768, fullscreen is 1920x1080
** (virt-viewer:5794): DEBUG: Display size request 1024x768 (desktop 1024x768)
** (virt-viewer:5794): DEBUG: Allocated 1024x768
** (virt-viewer:5794): DEBUG: Child allocate 1024x768
** (virt-viewer:5794): DEBUG: Display size request 50x50 (desktop 1024x768)
** (virt-viewer:5794): DEBUG: Allocated 1024x768
** (virt-viewer:5794): DEBUG: Child allocate 1024x768
** (virt-viewer:5794): DEBUG: Dispatch handler 7 1 0x26013d0
** (virt-viewer:5794): DEBUG: Update timeout 0x2600e70 1 0
** (virt-viewer:5794): DEBUG: Dispatch timeout 0x2600e70 0x3d15f1a030 1 0x2601220
** (virt-viewer:5794): DEBUG: Update timeout 0x2600e70 1 -1
** (virt-viewer:5794): DEBUG: Preparing main window resize
** (virt-viewer:5794): DEBUG: Decided todo 1024x768 (desktop is 1024x768, fullscreen is 1920x1080
** (virt-viewer:5794): DEBUG: Allocated 203x50
** (virt-viewer:5794): DEBUG: Child allocate 67x50
** (virt-viewer:5794): DEBUG: Dispatch handler 7 1 0x26013d0
** (virt-viewer:5794): DEBUG: Update timeout 0x2600e70 1 0
** (virt-viewer:5794): DEBUG: Dispatch timeout 0x2600e70 0x3d15f1a030 1 0x2601220
** (virt-viewer:5794): DEBUG: Update timeout 0x2600e70 1 -1
Comment 2 yuping zhang 2012-04-27 23:13:42 EDT
I know there is a bug about small windows size when switching off full screen.-Bug 805146
I filed this bug as the different operation leads to this appearance and the display is 203x50 after click "Automatically resize" which is smaller than the bug 805146.
Comment 3 RHEL Product and Program Management 2012-05-03 01:00:23 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-07-10 02:58:39 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 22:01:30 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 13 Marc-Andre Lureau 2013-05-08 10:16:39 EDT
this was fixed with bug 856610, afaict

*** This bug has been marked as a duplicate of bug 856610 ***

Note You need to log in before you can comment on or make changes to this bug.