Bug 856610 - [remote-viewer] Enabling auto resize results in wrong resolution
Summary: [remote-viewer] Enabling auto resize results in wrong resolution
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer   
(Show other bugs)
Version: 6.5
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
: 817206 (view as bug list)
Depends On: 845550 991291
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-12 12:24 UTC by Tomas Jamrisko
Modified: 2013-08-02 05:33 UTC (History)
10 users (show)

Fixed In Version: virt-viewer-0.5.2-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845550
Environment:
Last Closed: 2013-02-21 09:33:32 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0361 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-02-20 20:53:07 UTC

Description Tomas Jamrisko 2012-09-12 12:24:23 UTC
+++ This bug was initially created as a clone of Bug #845550 +++

Description of problem:

Connecting to a VM using remote-viewer and spice and later disabling and then reenabling automatic window resize results in window being rather small.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9.el6.i686


How reproducible:
Always

Steps to Reproduce:
1. Connect to a running VM (it doesn't necesarilly have to run vdagent)
2. Disable auto resize (view -> Automatically resize) (it should be enabled by default)
3. Enable auto resize
  
Actual results:
Window gets resized, and it's rather small, VM has to be scaled

Expected results:
Size of the window shouldn't change (or it should be 1:1 with VM resolution), definitely not tiny


Additional info:
Happens also in RHEL 6.3
Tested just with windows guests

Comment 3 Marc-Andre Lureau 2012-10-16 18:41:59 UTC
sent a propose fix to the ML

Comment 4 Dave Allan 2012-10-16 19:16:08 UTC
(In reply to comment #3)
> sent a propose fix to the ML

Can you provide a link to the mail archives?

Comment 5 Marc-Andre Lureau 2012-10-16 19:35:16 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > sent a propose fix to the ML
> 
> Can you provide a link to the mail archives?

https://www.redhat.com/archives/virt-tools-list/2012-October/msg00113.html

Comment 8 tingting zheng 2012-10-26 11:41:26 UTC
I can reproduce this issue with:virt-viewer-0.5.2-9.el6.x86_64

Tried with:
virt-viewer-0.5.2-16.el6.x86_64

Steps:
1. Connect to a running spice VM(it doesn't necesarilly have to run vdagent)
2. Use virt-viewer and remote-viewer to launch the guest.
3. Disable auto resize (view -> Automatically resize) (it should be enabled by default)
4. Enable auto resize,the size of the window doesn't change.

So change the bug to VERIFIED.

Comment 10 errata-xmlrpc 2013-02-21 09:33:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0361.html

Comment 11 Marc-Andre Lureau 2013-05-08 14:16:39 UTC
*** Bug 817206 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.