Bug 81733 - query page UI
query page UI
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-13 11:15 EST by David Balažic
Modified: 2013-06-23 23:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 02:07:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2003-01-13 11:15:10 EST
The query page ( https://bugzilla.redhat.com/bugzilla/query.cgi ) design is not 
very good.

First , the "Quick Search". One would expect tha this is separate form the rest 
of search elements, but it is not. Clicking on the "Search" button in "Quick 
Search" is the same as clicking "Search" in the "Query Action" section. This is 
a bit unintuitive.

Second , when skipping Quck Search and using the rest, in the "String Search" 
section , there is no entry for searching in the bug Summaries. One must use 
the Summary field in "Quick Search". This again is not very user friendly.

I recommend adding a "Summary" field to "String Search".

About "Quick Search" , either :

 - put a note that it will also be influenced by the search criteria below

or

 - make is separate from the other search criteria ( search _only_ by the 
summary )
Comment 1 Fred New 2003-01-23 16:28:09 EST
When I enter "contains all of the words/strings" and "firstboot Time" in Quick
Search, I don't find the bug I'm looking for - 82061.  Maybe Quick Search
doesn't consider closed bugs worth searching for.  There are about 10 duplicate
bugs reported against Phoebe and firstboot because a default query doesn't show
you 82061.  It may be complicated, but if Quick Search could also show bugs that
have been closed for less than 30 days, I think a lot of duplicates could be
eliminated.
Comment 2 David Balažic 2003-01-24 04:00:32 EST
Fred, that is becasue bug 82061 does not have the words "firstboot Time" in 
its "Summary" field. Its Summary is "Traceback loading Date and Time module",
you can find it by entering for example "traceback date time". You must also 
select "CLOSED" in the "Status" or set nothing in "Status", becasue the default 
is ti search for bugs that have Status  NEW, ASSIGNED or REOPENED.
Comment 3 David Lawrence 2006-04-08 13:53:05 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 4 David Lawrence 2008-09-16 12:49:44 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 5 Noura El hawary 2008-11-07 02:07:42 EST
This bug is no more relevant to bugzilla 3.2 , as the Search pages have completely changed in design and the don't include the sections mentioned in that bug report any more. So problems mentioned in this report are considered solved in the current bugzilla release.

Noura

Note You need to log in before you can comment on or make changes to this bug.