Bug 817574 - "Download All Files (Zip)" is not happening
"Download All Files (Zip)" is not happening
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.6-beta-1
Assigned To: Carlos Munoz
Joyce Chang
:
: 817723 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 10:22 EDT by Nilamdyuti
Modified: 2013-03-03 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version: Zanata version 1.6.0-alpha-3-SNAPSHOT (20120509-0019).
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of error message (1.65 MB, image/png)
2012-04-30 10:22 EDT, Nilamdyuti
no flags Details

  None (edit)
Description Nilamdyuti 2012-04-30 10:22:23 EDT
Created attachment 581197 [details]
Screenshot of error message

Description of problem:

While testing the new features of web UI in Zanata 1.6 alpha I encountered the following issue:

Download of a single .po file of a project is happening but download of all files as zip is not happening.

Version-Release number of selected component (if applicable):

Zanata 1.6 alpha

How reproducible:

Open any project in Zanata stage server (https://zanata-stage.app.eng.bos.redhat.com/) and try downloading all of it's files as zip.

Steps to Reproduce:
1. Login to Zanata stage server.
2. Open any project.
3. Click on files.
4. Click on "Download All Files (Zip)" on top right side.
  
Actual results:

After a confirmation dialog box and another dialog box, an error message "404 - Page Not Found" comes.

Expected results:

A proper page or a "Save Dialog" box should pop up.

Additional info:

Attached a screenshot of error message.
Comment 1 Joyce Chang 2012-05-08 00:41:18 EDT
*** Bug 817723 has been marked as a duplicate of this bug. ***
Comment 2 Carlos Munoz 2012-05-08 02:47:47 EDT
Joyce, I remember this happening a couple of weeks ago. The fix should be out on the test servers. Let me know if you see the same issue on the test servers although a quick runthrough showed no problems. In the meanwhile I'll put this bug on QA for tracking purposes.
Comment 3 Joyce Chang 2012-05-08 20:52:06 EDT
Yes, all test machine works properly regarding this issue except for stage machine which is a slightly older version than test machines. 
 

verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120509-0019).

Note You need to log in before you can comment on or make changes to this bug.