Bug 817841 - GTG+pyclutter == SIGSEGV
GTG+pyclutter == SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtg (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yanko Kaneti
Fedora Extras Quality Assurance
abrt_hash:e47ff4a4af97e7332a6bfc550b4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 10:36 EDT by Pedro Francisco
Modified: 2012-06-25 20:44 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (7.14 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
File: event_log (4.61 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
File: backtrace (48.33 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
File: maps (44.01 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
File: dso_list (13.87 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
File: build_ids (5.93 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
File: var_log_messages (7.83 KB, text/plain)
2012-05-01 10:36 EDT, Pedro Francisco
no flags Details
abrt server retrace for GTG crash after uninstalling ibus (128.17 KB, application/octet-stream)
2012-05-10 15:24 EDT, Pedro Francisco
no flags Details
strace -ff -e open -o gtg-opencalls.log gtg (24.43 KB, application/x-gzip)
2012-05-11 10:37 EDT, Pedro Francisco
no flags Details
rpm -Va output (2.74 KB, text/plain)
2012-05-11 10:52 EDT, Pedro Francisco
no flags Details

  None (edit)
Description Pedro Francisco 2012-05-01 10:36:15 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/gtg
comment:        Always: opening Getting Things Gnome
crash_function: gdk_display_manager_get_default_display
executable:     /usr/bin/python2.7
kernel:         3.3.4-1.fc17.i686.PAE
pid:            2469
pwd:            /home/pedro
remote_result:  NOTFOUND
time:           Tue 01 May 2012 03:29:06 PM WEST
uid:            1000
username:       pedro
xsession_errors: 

backtrace:      Text file, 49492 bytes
build_ids:      Text file, 6068 bytes
core_backtrace: Text file, 7309 bytes
dso_list:       Text file, 14201 bytes
event_log:      Text file, 4725 bytes
maps:           Text file, 45068 bytes
var_log_messages: Text file, 8018 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/pedro/2

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=sundaeII
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/pedro/keyring-q3f8iI/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=f450f1411bd5b7fc12c9163900000010-1335881019.205087-1357877578
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=33554437
:GNOME_KEYRING_CONTROL=/run/user/pedro/keyring-q3f8iI
:QTDIR=/usr/lib/qt-3.3
:QTINC=/usr/lib/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=pedro
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:ISE_EIFFEL=/home/pedro/progz/Eiffel68
:SSH_AUTH_SOCK=/run/user/pedro/keyring-q3f8iI/ssh
:USERNAME=pedro
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1009,unix/unix:/tmp/.ICE-unix/1009
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/pedro/.local/bin:/home/pedro/bin
:MAIL=/var/spool/mail/pedro
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:ISE_PLATFORM=linux-x86
:PWD=/home/pedro
:XMODIFIERS=@im=none
:'EDITOR=nano -w'
:GNOME_KEYRING_PID=1007
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/pedro
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=pedro
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-cBherkNyj3,guid=378aedc7b9f6989b2dd128430000002b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/pedro
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-pedro-N8iObn/database
:_=/usr/bin/gtg

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15936                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15936                15936                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/0
:pos:	0
:flags:	02
:1:/dev/pts/0
:pos:	0
:flags:	02
:2:/dev/pts/0
:pos:	0
:flags:	02
:3:socket:[58033]
:pos:	0
:flags:	02004002
:4:socket:[57924]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:/dev/urandom
:pos:	0
:flags:	02100000
:7:socket:[58027]
:pos:	0
:flags:	02004002
:8:/dev/dri/card0
:pos:	0
:flags:	02
:9:socket:[58034]
:pos:	0
:flags:	02004002
:10:/tmp/ffiHeNVa8 (deleted)
:pos:	0
:flags:	02

smolt_data:
:
:
:General
:=================================
:UUID: c547e0f8-8b76-4a21-8603-b9d5d9409c4d
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 2992.80
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     T5250  @ 1.50GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1500
:System Memory: 2008
:System Swap: 2502
:Vendor: Hewlett-Packard
:System: HP Pavilion dv6500 Notebook PC Rev 1
:Form factor: Notebook
:Kernel: 3.3.4-1.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4332:33078:4156:12492) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10752:4156:12492) pci, agpgart-intel, HOST/PCI, Mobile PM965/GM965/GL960 Memory Controller Hub
:(32902:10302:4156:12492) pci, None, SERIAL, 82801H (ICH8 Family) SMBus Controller
:(32902:10281:4156:12492) pci, ahci, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller
:(32902:10320:4156:12492) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
:(32902:10261:4156:12492) pci, None, PCI/ISA, 82801HEM (ICH8M) LPC Interface Controller
:(32902:16930:4156:4956) pci, iwl3945, NETWORK, Compaq 6710b or nx9420 Notebook
:(32902:10289:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #2
:(32902:9288:4156:12492) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10290:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #3
:(32902:10294:4156:12492) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #1
:(32902:10298:4156:12492) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #2
:(32902:10754:4156:12492) pci, i915, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (primary)
:(32902:10755:4156:12492) pci, None, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (secondary)
:(32902:10303:4156:12492) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4156:12492) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10315:4156:12492) pci, snd_hda_intel, MULTIMEDIA, 82801H (ICH8 Family) HD Audio Controller
:(32902:10292:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #4
:(32902:10288:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #1
:(32902:10313:4156:12492) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 6
:(4480:2098:4156:12492) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4156:12492) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:1426:4156:12492) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(4480:2130:4156:12492) pci, None, BASE, xD-Picture Card Controller
:(32902:10293:4156:12492) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda6 / ext4 4096 4096 3833262 1918830 1880447 966656 736958 736958
:/dev/sda8 /home ext4 4096 4096 19072132 2385697 1430533 4775936 4182102 4182102
:/dev/sda5 /boot ext2 1024 1024 495759 420952 395250 128520 128241 128241
:
Comment 1 Pedro Francisco 2012-05-01 10:36:20 EDT
Created attachment 581396 [details]
File: core_backtrace
Comment 2 Pedro Francisco 2012-05-01 10:36:22 EDT
Created attachment 581397 [details]
File: event_log
Comment 3 Pedro Francisco 2012-05-01 10:36:24 EDT
Created attachment 581398 [details]
File: backtrace
Comment 4 Pedro Francisco 2012-05-01 10:36:27 EDT
Created attachment 581399 [details]
File: maps
Comment 5 Pedro Francisco 2012-05-01 10:36:30 EDT
Created attachment 581400 [details]
File: dso_list
Comment 6 Pedro Francisco 2012-05-01 10:36:32 EDT
Created attachment 581401 [details]
File: build_ids
Comment 7 Pedro Francisco 2012-05-01 10:36:35 EDT
Created attachment 581402 [details]
File: var_log_messages
Comment 8 Thomas Spura 2012-05-01 11:16:01 EDT
Thanks for the bug report.

The first python releated frame is around #78.

All above are gtk/ibus related and it's likely a ibus bug than a gtk one.

#0  gdk_display_manager_get_default_display (manager=0x0) at gdkdisplaymanager.c:285
No locals.
#1  0x4648e62d in gdk_display_get_default () at gdkdisplaymanager.c:303
No locals.
#2  0xb641b995 in ibus_im_context_class_init (class=0xa151aa0) at ibusimcontext.c:504
        im_context_class = <optimized out>
        gobject_class = <optimized out>
        __PRETTY_FUNCTION__ = "ibus_im_context_class_init"
#3  0x41a36ad6 in type_class_init_Wm (pclass=0x9cc6820, node=0xa151a08) at gtype.c:2219
        slist = <optimized out>
        init_slist = <optimized out>
        i = 0
        class = 0xa151aa0
        entries = <optimized out>
        entry = <optimized out>
        bnode = <optimized out>
        pnode = 0x982e5a0

Reassigning to ibus.
Comment 9 fujiwara 2012-05-01 22:12:23 EDT
Which python application did you use?
I cannot reproduce your problem.
ibus requires to open $DISPLAY and I don't think it's a bug.
Comment 10 Pedro Francisco 2012-05-02 02:33:34 EDT
"Getting Things Gnome"
(...)
cmdline:        /usr/bin/python /usr/bin/gtg
comment:        Always [happens]: [when] opening Getting Things Gnome
(...)

# rpm -qa gtg python ibus
python-2.7.3-3.fc17.i686
gtg-0.2.4-6.fc17.noarch
ibus-1.4.99.20120428-1.fc17.i686

Running from a Gnome Shell session.
Comment 11 fujiwara 2012-05-02 06:34:09 EDT
(In reply to comment #10)
> "Getting Things Gnome"
> (...)
> cmdline:        /usr/bin/python /usr/bin/gtg
> comment:        Always [happens]: [when] opening Getting Things Gnome
> (...)
> 
> # rpm -qa gtg python ibus
> python-2.7.3-3.fc17.i686
> gtg-0.2.4-6.fc17.noarch
> ibus-1.4.99.20120428-1.fc17.i686
> 
> Running from a Gnome Shell session.

I tried gtg and I cannot reproduce your problem.
Are you still able to reproduce your problem?

I wonder how do you start the desktop session.
Comment 12 Pedro Francisco 2012-05-02 06:55:19 EDT
$ gtg

** (process:16664): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:16664): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:16664): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning: cannot register existing type `GdkDisplayManager'
  self.window.show()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning: g_once_init_leave: assertion `result != 0' failed
  self.window.show()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning: g_type_register_static: assertion `parent_type > 0' failed
  self.window.show()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
  self.window.show()
Segmentation fault (core dumped)



I'm on x86, I'll try on x86-64 (tomorrow or after) to check if it happens there was well.
Session was started from GDM.
Comment 13 fujiwara 2012-05-06 22:31:16 EDT
(In reply to comment #12)
> $ gtg
> 
> ** (process:16664): WARNING **: Trying to register gtype 'GMountMountFlags' as
> enum when in fact it is of type 'GFlags'
> 
> ** (process:16664): WARNING **: Trying to register gtype 'GDriveStartFlags' as
> enum when in fact it is of type 'GFlags'
> 
> ** (process:16664): WARNING **: Trying to register gtype 'GSocketMsgFlags' as
> enum when in fact it is of type 'GFlags'
> Gtk-Message: Failed to load module "pk-gtk-module"
> /usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning:
> cannot register existing type `GdkDisplayManager'
>   self.window.show()
> /usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning:
> g_once_init_leave: assertion `result != 0' failed
>   self.window.show()
> /usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning:
> g_type_register_static: assertion `parent_type > 0' failed
>   self.window.show()
> /usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2004: Warning:
> g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
>   self.window.show()
> Segmentation fault (core dumped)
> 
> 
> 
> I'm on x86, I'll try on x86-64 (tomorrow or after) to check if it happens there
> was well.
> Session was started from GDM.

I don't think this error is caused by ibus.
You could disable ibus with 'im-chooser' command.
Comment 14 Pedro Francisco 2012-05-10 15:24:18 EDT
Created attachment 583658 [details]
abrt server retrace for GTG crash after uninstalling ibus

Uninstalled ibus; tried to run GTG, crash as well, but I could see main window being drawn for half a second.

$ sudo yum list installed |grep -i ibus
libusb.i686                            1:0.1.3-10.fc17          @anaconda-0     
libusb1.i686                           1.0.9-0.6.rc1.fc17       @anaconda-0     
libuser.i686                           0.57.6-1.fc17            @anaconda-0     
libuser-python.i686                    0.57.6-1.fc17            @anaconda-0     
scribus.i686                           1.4.0-5.fc17             @fedora
Comment 15 Yanko Kaneti 2012-05-11 03:59:43 EDT
Please try the following and paste the oputput here.

- logout/login -  I don't understand ibus but I'd like to make sure there are no leftovers in the current session

$ echo $DISPLAY  

$ python -c 'from gtk.gdk import Screen'
Comment 16 Pedro Francisco 2012-05-11 07:15:27 EDT
As I've found out thanks to #808789 , $DISPLAY is different depending on if a program is started by Nautilus or by someone else (and I typically start consoles by Nautilus). So, I did it twice:

$ echo $DISPLAY
:0.0
[pedro@sundaeII ~]$ python -c 'from gtk.gdk import Screen'

** (process:21197): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:21197): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:21197): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
$

--------------------------------
$ echo $DISPLAY
:0
$ python -c 'from gtk.gdk import Screen'

** (process:21259): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:21259): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:21259): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
$
Comment 17 Yanko Kaneti 2012-05-11 07:56:20 EDT
So pygtk appears to be functional....
How about trying gtg again in both cases ?
Comment 18 Pedro Francisco 2012-05-11 09:16:44 EDT
$ echo $DISPLAY; gtg 
:0

** (process:1667): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:1667): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:1667): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2005: Warning: cannot register existing type `GdkWindow'
  gtk.main()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2005: Warning: g_once_init_leave: assertion `result != 0' failed
  gtk.main()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2005: GtkWarning: gdk_cairo_create: assertion `GDK_IS_WINDOW (window)' failed
  gtk.main()
Segmentation fault (core dumped)

------------------------------------------------
$ echo $DISPLAY; gtg 
:0.0

** (process:1812): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:1812): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:1812): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2005: Warning: cannot register existing type `GdkWindow'
  gtk.main()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2005: Warning: g_once_init_leave: assertion `result != 0' failed
  gtk.main()
/usr/lib/python2.7/site-packages/GTG/taskbrowser/browser.py:2005: GtkWarning: gdk_cairo_create: assertion `GDK_IS_WINDOW (window)' failed
  gtk.main()
Segmentation fault (core dumped)
Comment 19 Pedro Francisco 2012-05-11 09:20:16 EDT
It's not PyGTK:

$ wget http://www.pygtk.org/pygtk2tutorial/examples/helloworld.py
--2012-05-11 14:18:18--  http://www.pygtk.org/pygtk2tutorial/examples/helloworld.py
Resolving www.pygtk.org... 209.132.180.176
Connecting to www.pygtk.org|209.132.180.176|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3093 (3.0K) [text/plain]
Saving to: `helloworld.py'

100%[======================================>] 3,093       --.-K/s   in 0s      

2012-05-11 14:18:18 (94.7 MB/s) - `helloworld.py' saved [3093/3093]

$ python helloworld.py 

** (process:1863): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:1863): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:1863): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
Hello World
destroy signal occurred
Comment 20 Yanko Kaneti 2012-05-11 09:54:25 EDT
Well I also can't reproduce the issue, and I've just tried the latest f17-branched nightly live cd compose in a vm. Installed gtg. Ran without issues.
Sorry but I am at a loss here.

Perhaps you could do a 
$ strace -ff -e open -o gtg-opencalls.log gtg

and attach the gtg-opencalls.log file
- perhaps some stray python library in a non standard location superseeds the ones from the distribution ?

as a last resort I would do a rpm -Va  to check if the files in the filesystem match the rpmdb./
Comment 21 Pedro Francisco 2012-05-11 10:29:55 EDT
Are you on x86? I wanted to test on a x86_64 but still haven't done it (most devs seem to be running x86_64 nowadays)
Comment 22 Pedro Francisco 2012-05-11 10:37:21 EDT
Created attachment 583861 [details]
strace -ff -e open -o gtg-opencalls.log gtg
Comment 23 Pedro Francisco 2012-05-11 10:52:57 EDT
Created attachment 583862 [details]
rpm -Va output
Comment 24 Yanko Kaneti 2012-05-11 11:17:12 EDT
I've tried both x86 and x86_64 livecds in a vm. Staring for the past 10 minutes at the open log but I I can spot any significant difference , sorry. I am done for the day.
Comment 25 Pedro Francisco 2012-05-11 11:45:22 EDT
Ok, thank you for your help :)
Comment 26 Pedro Francisco 2012-05-12 20:41:47 EDT
If you have uninstalled all ibus packages, removing /usr/share/themes/Adwaita/gtk-2.0/gtkrc will allow GTG to start.

If you have ibus installed, it will crash somewhere else.
Comment 27 Edward Sheldrake 2012-05-15 15:37:34 EDT
The backtraces and dso lists indicate that both libgdk-x11-2.0.so.0.2400.10 from gtk2 and libgdk-3.so.0.400.1 from gtk3 have been loaded - gdk3 seems to have been dragged in by clutter.

Since the GDK backend was enabled in clutter-1.10.0-2, clutter requires gdk from gtk3 - and you can't mix both gtk2 and gtk3 in the same process.
Comment 28 Pedro Francisco 2012-05-15 15:50:35 EDT
Ok...... but could you explain, if you don't mind:
* why I can start gtg by removing ibus* and deleting /usr/share/themes/Adwaita/gtk-2.0/gtkrc ?
* why it works on "both x86 and x86_64 livecds in a vm"?
Comment 29 Edward Sheldrake 2012-05-15 17:05:04 EDT
(In reply to comment #28)
> Ok...... but could you explain, if you don't mind:
> * why I can start gtg by removing ibus* and deleting
> /usr/share/themes/Adwaita/gtk-2.0/gtkrc ?
> * why it works on "both x86 and x86_64 livecds in a vm"?

I would if I could! Deleting Adwaita/gtk-2.0/gtkrc means the clearlooks gtk2 engine won't be used.

Anyway, I have discovered that you can launch gtg with the Adwaita gtk2 theme if you don't have pyclutter installed (I have also just discovered nothing on my system needed pyclutter anymore). Alternatively, you can delete:

/usr/lib/python2.7/site-packages/GTG/plugins/geolocalized_tasks/
/usr/lib/python2.7/site-packages/GTG/plugins/geolocalized-tasks.gtg-plugin

gtg doesn't require pyclutter or all the other stuff that would be needed for the geolocalized tasks plugin, which looks like the only thing in gtg that uses clutter.
Comment 30 Pedro Francisco 2012-05-15 18:06:35 EDT
BINGO!

Probably pyclutter isn't installed by default!

Chaging
Comment 31 Pedro Francisco 2012-05-15 18:08:27 EDT
I meant "changing the title"...

Thanks for the diagnosis, Edward Sheldrake!!

P.S.: possibly the bug is in pyclutter and not GTG...?
Comment 32 Peter Robinson 2012-06-14 09:55:57 EDT
(In reply to comment #31)
> I meant "changing the title"...
> 
> Thanks for the diagnosis, Edward Sheldrake!!
> 
> P.S.: possibly the bug is in pyclutter and not GTG...?

Nope, pyclutter uses gtk3. If gtg is loading it for some reason it's likely gtg is at fault. The reason you likely don't see it in a VM is because gnome is probably running in fallback mode where clutter isn't used.
Comment 33 Yanko Kaneti 2012-06-14 10:28:09 EDT
Thanks for the diagnosis, Edward. I must've been blind..

This whole py+clutter+gtk(2|3) fiasco could have been avoided on the clutter/pyclutter side, but that's already water under the bridge.

Moving the bug back to gtg, where one approach to deal with is to ignore it and instruct users to remove pyclutter. Or disable the geolocalized_tasks plugin if they for some reason need pyclutter.
Another is to remove the geolocalized_tasks plugin in an update.
Comment 34 Fedora Update System 2012-06-14 11:31:20 EDT
gtg-0.2.4-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gtg-0.2.4-7.fc17
Comment 35 Fedora Update System 2012-06-15 08:33:59 EDT
Package gtg-0.2.4-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtg-0.2.4-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9494/gtg-0.2.4-7.fc17
then log in and leave karma (feedback).
Comment 36 Fedora Update System 2012-06-25 20:44:59 EDT
gtg-0.2.4-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.