Bug 817857 - kdm/workspace: restart/shutdown fails
kdm/workspace: restart/shutdown fails
Status: CLOSED DUPLICATE of bug 816842
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: 815091 816842
Blocks: F17Blocker-kde
  Show dependency treegraph
 
Reported: 2012-05-01 11:38 EDT by Rex Dieter
Modified: 2012-05-02 08:11 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 08:11:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-05-01 11:38:49 EDT
I'd been testing lightdm for awhile, which seemed to have problems with restart/shutdown (due to it's reliance on ConsoleKit apparently), but went back to using kdm recently.

Scary part is that restart/shutdown still didn't work.

Symptoms are that the reboot/shutdown process seems to proceed normally at first... ends my X session, bounces back to plymouth, tty's end/close... then... stuck.

same thing happens in either in kde workspace or kdm.

The only thing that *does* continue to reliably restart/shutdown is gdm :(
Comment 1 Rex Dieter 2012-05-01 11:39:56 EDT
OK, so I suspect our systemd integration to be at fault here, and that some recent systemd update changed or broke things here.

First thing I'll try is downgrading systemd
Comment 2 Rex Dieter 2012-05-01 12:29:01 EDT
oh boy, even more insidious, before getting to downgrade systemd, my restart attempt using gdm just now failed too.

More findings:
kdm works in the case of initial boot, and before any user logs in.  restart/shutdown is fine
Comment 3 Rex Dieter 2012-05-01 12:32:47 EDT
Heh, bug #817635 mentions the shutdown problem, which was eventually dup'd against bug #815091 too.  Let's hope it's related.  fun!
Comment 4 Rex Dieter 2012-05-01 13:32:58 EDT
More testing on the restart/shutdown case, seems it fails fairly reliably (maybe 3 out of 4 attempts), even with the test-candidate wpa-supplicant build from bug #815091

that's probably all the time I have to test this for today.

next steps to try:
with kdm: login, logout, try restart/shutdown from kdm
with gdm: same
Comment 5 Kevin Kofler 2012-05-01 16:25:28 EDT
The systemd integration in kde-workspace should have no effect when KDM is in use. I suspect this is related to bug #796969, was something changed (again?!) in that area?
Comment 6 Rex Dieter 2012-05-01 23:39:18 EDT
bug #816842 may be relevant too
Comment 7 Martin Kho 2012-05-02 07:15:01 EDT
Hi,

In /var/log/messages I see:

May  2 09:53:45 ps-1866 kdm[608]: Cannot execute 'grub-reboot': not in $PATH.
May  2 09:53:47 ps-1866 kdm[608]: Cannot execute 'grub-reboot': not in $PATH.
May  2 09:53:47 ps-1866 kdm: :0[815]: Fatal X server IO error: Interrupted system call


Relevant?

Martin Kho
Comment 8 Rex Dieter 2012-05-02 08:11:26 EDT
I'm pretty sure not, that likely has more to do with grub integration (which isn't enabled by default).

OK, I'm convinced this is indeed bug #816842 , see 
https://bugzilla.redhat.com/show_bug.cgi?id=816842#c12
in particular.  reboot/shutdown *eventually* succeeds, you only have to wait ~2 minutes for it to happen.

*** This bug has been marked as a duplicate of bug 816842 ***

Note You need to log in before you can comment on or make changes to this bug.