Bug 817968 - Automatic restart of service causes its BoundBy dependencies to stop but not start again
Automatic restart of service causes its BoundBy dependencies to stop but not ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 817990
  Show dependency treegraph
 
Reported: 2012-05-01 19:15 EDT by David Ward
Modified: 2012-06-05 19:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 06:35:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[1/4] schedule JOB_RESTART from SERVICE_AUTO_RESTART state (1.20 KB, patch)
2012-05-01 19:15 EDT, David Ward
no flags Details | Diff
[2/4] service: actually delay auto-restart if another job is pending (741 bytes, patch)
2012-05-01 19:16 EDT, David Ward
no flags Details | Diff
[3/4] service: fix auto-restart handling in service_stop() (1.79 KB, patch)
2012-05-01 19:16 EDT, David Ward
no flags Details | Diff
[4/4] service: fix auto-restart handling in service_start() (1.45 KB, patch)
2012-05-01 19:17 EDT, David Ward
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 45511 None None None Never

  None (edit)
Description David Ward 2012-05-01 19:15:00 EDT
Created attachment 581492 [details]
[1/4] schedule JOB_RESTART from SERVICE_AUTO_RESTART state

A service may automatically restart if the Restart option is set (for example, if the service fails and has Restart=on-failure). When this happens, any other services that BindTo this service are stopped, but they do not start again after the automatic restart is complete.

This was fixed upstream in commit 48bb58769a00e8e50a617ebbfff84599a0350fa5. Unfortunately it introduced a regression in OnFailure handling, but a three-patch fix for that has been posted and is waiting upstream review.

This bug is created to track the inclusion of these fixes in Fedora. The patches attached to this bug are the same as the four patches sent upstream, except they have been backported for systemd 44, which is currently in rawhide and f17.
Comment 1 David Ward 2012-05-01 19:16:22 EDT
Created attachment 581494 [details]
[2/4] service: actually delay auto-restart if another job is pending
Comment 2 David Ward 2012-05-01 19:16:52 EDT
Created attachment 581495 [details]
[3/4] service: fix auto-restart handling in service_stop()
Comment 3 David Ward 2012-05-01 19:17:23 EDT
Created attachment 581496 [details]
[4/4] service: fix auto-restart handling in service_start()
Comment 4 Adam Tkac 2012-05-03 07:33:26 EDT
Please apply this fix also for systemd in Fedora 16.
Comment 6 Fedora Update System 2012-05-22 03:29:50 EDT
systemd-44-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-8127/systemd-44-12.fc17
Comment 7 Fedora Update System 2012-05-22 03:53:18 EDT
systemd-37-24.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-8164/systemd-37-24.fc16
Comment 8 Fedora Update System 2012-05-22 11:56:12 EDT
Package systemd-44-12.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-44-12.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8127/systemd-44-12.fc17
then log in and leave karma (feedback).
Comment 9 David Ward 2012-05-25 09:06:37 EDT
The testing packages for Fedora 16 and 17 resolve the issue; karma added. Also this should now be fixed in rawhide, as these changes are included in systemd 183. http://koji.fedoraproject.org/koji/buildinfo?buildID=320458
Comment 10 Michal Schmidt 2012-05-25 09:16:59 EDT
David, thank you for the patches and for testing the builds. I saw your karma.
I'm going to let the builds stay in updates-testing for a few more days to give users a chance to notice any regressions.
Comment 11 Fedora Update System 2012-05-29 06:35:07 EDT
systemd-44-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 David Ward 2012-06-02 16:33:22 EDT
(In reply to comment #10)
> David, thank you for the patches and for testing the builds. I saw your
> karma.
> I'm going to let the builds stay in updates-testing for a few more days to
> give users a chance to notice any regressions.

Michal, if you would still like additional testing of the Fedora 16 build, can you please send an email to test@lists.fedoraproject.org and solicit testers?  This build is not being listed on their automated emails because it has reached critical path approval, so I think it has fallen off everyone's radar.

(I tried to subscribe to the list but it's not going through for me.)
Comment 13 Fedora Update System 2012-06-05 19:11:17 EDT
systemd-37-25.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.