Bug 818136 - [RFE] Geo-replication Fail-over
[RFE] Geo-replication Fail-over
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-User_Guide (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity medium
: Release Candidate
: RHGS 2.0.0
Assigned To: Divya
amainkar
: FutureFeature
: 821869 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 06:22 EDT by Divya
Modified: 2015-05-13 11:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-10 03:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Divya 2012-05-02 06:22:16 EDT
Date expected to be completed:

SME: Venky

page count:

graphics count:

link to the actual
section:
Comment 1 Divya 2012-05-16 02:39:50 EDT
*** Bug 821869 has been marked as a duplicate of this bug. ***
Comment 3 Vijaykumar Koppad 2012-06-22 10:09:29 EDT
As of I have understood about the f/o and f/b feature is , we are not giving out the detailed steps involved in the Fail-over and Fail-back to the user , but rather we just mention, what this feature is capable of and how should a customer approach, to use this feature. For that , I think this is sufficient in the documentation.  

      Red Hat Storage 2.0 supports Geo-Replication failover and failback. If the master goes down, you can trigger a failover procedure so that the slave can be replaced as the master. During this time, all I/O operations including writes and reads are done on the slave (now acting as master). When the original master (OM) is back online, you can trigger a failback procedure on the original slave (OS) so that it syncs the delta back to the master.

And then in the note section, we can mention,

Note : "Implementation of f/o and f/b for production mandates a  Red Hat Professional Services engagement. Please contact your Red Hat representative for more information." Something like that.

But Documentation already has the detailed steps to execute. I feel we should remove that.
Comment 4 Divya 2012-06-25 05:20:37 EDT
I have added a Warning on engaging Red Hat Professional Services and retained instructions on triggering Failover and Failback based on Sayan's suggestion. The updated documentation is available at: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/ch11s05.html

Note You need to log in before you can comment on or make changes to this bug.