Bug 818192 - [TEXT] Unclear error message when trying to destroy ISO domain.
[TEXT] Unclear error message when trying to destroy ISO domain.
Status: CLOSED DUPLICATE of bug 819279
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Vered Volansky
yeylon@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 08:21 EDT by Leonid Natapov
Modified: 2016-04-18 02:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-30 02:00:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image (127.69 KB, image/jpeg)
2012-05-02 08:21 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2012-05-02 08:21:41 EDT
Created attachment 581597 [details]
image

When trying to destroy ISO domain while Storage domain status is UP getting the following error message:
---------
Error: Cannot destroy Storage. Storage status is unknown.Please check Storage domain and retry the operation.
---------
The storage status is not uknown. Should be changed to illegal (like in 3.0) or specify exactly that ISO cannot be removed when storage domain is UP.

image attached.

In the backend log getting cando action with the word "illegal" not unknown.

CanDoAction of action ForceRemoveStorageDomain failed. Reasons:VAR__ACTION__DESTROY_DOMAIN,VAR__TYPE__STORAGE__DOMAIN,ACTION_TYPE_FAILED_STORAGE_DOMAIN_STATUS_ILLEGAL2
Comment 1 Vered Volansky 2012-09-30 01:16:37 EDT
This is no longer the case, when trying to reproduce I get the following error message:
---------
Error while executing action: Cannot destroy Storage. Storage status is Active.Please check Storage domain and retry the operation.
---------
Comment 2 Allon Mureinik 2012-09-30 02:00:37 EDT
This bug is a duplicate of #819279, closing.
(Although this one was reported first, so technically it should be the other way round, but I prefer leaving the bug with the fix info and all the correspondence as the "live" one)

*** This bug has been marked as a duplicate of bug 819279 ***

Note You need to log in before you can comment on or make changes to this bug.