Bug 818309 - jboss hooks (particularly configure) doesn't output anything back to the broker
jboss hooks (particularly configure) doesn't output anything back to the broker
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Reopened, Triaged
: 852524 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 13:47 EDT by Dan McPherson
Modified: 2015-05-14 18:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-16 12:37:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2012-05-02 13:47:33 EDT
Description of problem:

jboss hooks (particularly configure) doesn't output anything back to the broker

Instead they redirect output to a log.  This is problematic if a failure occurs since the app is immediately destroyed.  I don't think there is a technical reason we want jboss to behave differently than the other types.  Although I know this was done originally because of output streams being left open by starting jboss.  We need to find a solution that can solve the steam being left open issue and still return the output to the caller.

Note: A simple hack might be to just cat the current log at the end.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jhon Honce 2012-08-29 14:37:33 EDT
*** Bug 852524 has been marked as a duplicate of this bug. ***
Comment 2 Mike McGrath 2013-02-13 14:28:33 EST
Any update here?  Will the new cartridge format fix this?
Comment 3 Jhon Honce 2013-02-14 11:54:10 EST
This will be corrected when ported to new cartridge format.
Comment 4 Dan McPherson 2013-02-14 12:21:46 EST
If a bug is fixed you can mark it ON_QA.  Shouldn't close a bug without it going through QE.
Comment 5 Mike McGrath 2013-04-16 12:37:05 EDT
We think this is going to be as fixed as possible.  It's not perfect but it's better than it was before as a result of some re-work with the v2 format.

Note You need to log in before you can comment on or make changes to this bug.