Bug 852524 - Jboss cartridge steals file descriptors
Jboss cartridge steals file descriptors
Status: CLOSED DUPLICATE of bug 818309
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
Depends On:
  Show dependency treegraph
Reported: 2012-08-28 15:47 EDT by Jhon Honce
Modified: 2015-05-14 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-29 14:37:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jhon Honce 2012-08-28 15:47:09 EDT
Description of problem:
The jboss cartridge either closes or redirects hook output to cartridge private logs. This implies the information needed for debugging is lost if a jboss gear fails to be successfully created and started.  All other cartridges allow this information to flow back to the broker.

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1. create a jboss cartridge
Actual results:
Workflow destroys information needed for debugging

Expected results:
Allow broker to log details of failure

Additional info:
Comment 1 Jhon Honce 2012-08-29 14:37:33 EDT

*** This bug has been marked as a duplicate of bug 818309 ***

Note You need to log in before you can comment on or make changes to this bug.