Bug 818373 - qemu+ssh connections not using the username specified
qemu+ssh connections not using the username specified
Status: CLOSED DUPLICATE of bug 811397
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 17:40 EDT by Joe Julian
Modified: 2012-05-16 13:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 13:58:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2012-05-02 17:40:27 EDT
Description of problem:
Configuring a connection qemu+ssh://root@vmhost1.domain.dom/system and trying to connect to that opens the dialog asking for the password for myuser@vmhost1.domain.dom

Version-Release number of selected component (if applicable):
virt-manager-0.9.1-3.fc17.noarch

How reproducible:
always

Steps to Reproduce:
1. Add Connection
2. Configure and save the connection as:
    Hypervisor: QEMU/KVM
    Connect to remote host: Checked
    Method: SSH
    Username: root
    Hostname: vmhost1.domain.dom
3. Attempt to connenct

Actual results: The password dialog, titled "OpenSSH", opens asking for the password for myuser@vmhost1.domain.dom where myuser is the username of the user running virt-manager


Expected results: The password dialog should be asking for the password for root@vmhost1.domain.dom
Comment 1 Cole Robinson 2012-05-16 13:58:34 EDT

*** This bug has been marked as a duplicate of bug 811397 ***

Note You need to log in before you can comment on or make changes to this bug.