Bug 818402 - SELinux is preventing /usr/sbin/tmpwatch from 'write' accesses on the directory locks.
SELinux is preventing /usr/sbin/tmpwatch from 'write' accesses on the directo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6d816c92ed2a7b4a5769f876d8b...
:
: 818403 818405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 21:34 EDT by Paul DeLong
Modified: 2012-05-03 03:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 03:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul DeLong 2012-05-02 21:34:22 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/tmpwatch from 'write' accesses on the directory locks.
time:           Wed 02 May 2012 09:33:49 PM EDT

description:
:SELinux is preventing /usr/sbin/tmpwatch from 'write' accesses on the directory locks.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that tmpwatch should be allowed write access on the locks directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep tmpwatch /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tmpreaper_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:nsplugin_home_t:s0
:Target Objects                locks [ dir ]
:Source                        tmpwatch
:Source Path                   /usr/sbin/tmpwatch
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           tmpwatch-2.10.3-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc16.x86_64 #1
:                              SMP Thu Mar 29 18:37:19 UTC 2012 x86_64 x86_64
:Alert Count                   17
:First Seen                    Sun 15 Apr 2012 01:27:11 PM EDT
:Last Seen                     Wed 02 May 2012 09:40:03 AM EDT
:Local ID                      39c00973-b630-4bbe-94f9-22cf83cb1b27
:
:Raw Audit Messages
:type=AVC msg=audit(1335966003.824:8782): avc:  denied  { write } for  pid=1492 comm="tmpwatch" name="locks" dev="dm-1" ino=1843882 scontext=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:nsplugin_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1335966003.824:8782): arch=x86_64 syscall=unlink success=no exit=EACCES a0=16bbd63 a1=40470b a2=16ab270 a3=7fff9c8d4cc8 items=0 ppid=1490 pid=1492 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=946 comm=tmpwatch exe=/usr/sbin/tmpwatch subj=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 key=(null)
:
:Hash: tmpwatch,tmpreaper_t,nsplugin_home_t,dir,write
:
:audit2allow
:
:#============= tmpreaper_t ==============
:#!!!! The source type 'tmpreaper_t' can write to a 'dir' of the following types:
:# kismet_log_t, rpm_var_cache_t, httpd_sys_rw_content_t, print_spool_t, amavis_spool_t, man_t, file_t, tmpfile, sandbox_file_t, httpd_cache_t
:
:allow tmpreaper_t nsplugin_home_t:dir write;
:
:audit2allow -R
:
:#============= tmpreaper_t ==============
:#!!!! The source type 'tmpreaper_t' can write to a 'dir' of the following types:
:# kismet_log_t, rpm_var_cache_t, httpd_sys_rw_content_t, print_spool_t, amavis_spool_t, man_t, file_t, tmpfile, sandbox_file_t, httpd_cache_t
:
:allow tmpreaper_t nsplugin_home_t:dir write;
:
Comment 1 Miroslav Grepl 2012-05-03 03:43:08 EDT
*** Bug 818403 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-05-03 03:43:13 EDT
*** Bug 818405 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-05-03 03:48:21 EDT
It looks like you moved the "locks" directory from to the /tmp directory.

Either remove this directory or run

# chcon -Rt user_tmp_t /tmp/locks

If I am wrong, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.