Bug 818767 - man page for rhn-migrate-classic-to-rhsm should note that additional subscription-manager-migration-data must be installed
man page for rhn-migrate-classic-to-rhsm should note that additional subscrip...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Documentation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-03 18:20 EDT by John Sefler
Modified: 2012-09-18 07:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-05-03 18:20:03 EDT
Description of problem:
Because subscription-manager-migration can be installed without subscription-manager-migration-data (both of which are not installed by default), it is possible to run rhn-migrate-classic-to-rhsm and fail; see reference bug 816377 and bug 811779.  Unfortunately the user is not told via the failure messages what to do. Reading the man page also does not tell the user what to do.

We need an extra blurb in the man page for rhn-migrate-classic-to-rhsm (and install-num-migrate-to-rhsm too) that somehow states that package subscription-manager-migration-data is required for the migration tools to be successful.

Version-Release number of selected component (if applicable):
[root@bigisis ~]# rpm -q subscription-manager-migration
subscription-manager-migration-0.99.16-1.el6.x86_64
[root@bigisis ~]# man -P cat rhn-migrate-classic-to-rhsm | grep Version
Version 0.2                     December 8 2011 rhn-migrate-classic-to-rhsm(8)
[root@bigisis ~]# 


How reproducible:


Steps to Reproduce:
[root@bigisis ~]# man -P cat rhn-migrate-classic-to-rhsm | grep -i data
[root@bigisis ~]# 

^^ No references to data at all.  Expected something in the man page to tell me to yum install subscription-manager-migration-data.
Comment 1 Deon Ballard 2012-05-03 21:37:41 EDT
Committed into the 6.3 branch:
52582cbe51d67bdbc45b82c9ff020c2b9644e77e

And committed into master:
db5910e1247f4f92d270e53816f8c20a55589bcd

Sefler, I just added a couple of sentences at the beginning, in the description, that subscription-manager-migration-data is required for the scripts to work, and then I added it to the file list at the end. Think that's good enough, or should I figure out how to make it more obvious?
Comment 4 John Sefler 2012-05-10 18:26:21 EDT
Verifying Version....

[root@ibm-ls21-03 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-0.99.17-1.el6.i686


Snippets from...
[root@ibm-ls21-03 ~]# man -P cat rhn-migrate-classic-to-rhsm
<---SNIP--->
       This  script  migrates  configuration,  from a channel-based sub-
       scription framework to a  certificate-based  subscription  frame-
       work.  While  the rhn-migrate-classic-to-rhsm script performs the
       migration operation, the data used to map  the  channels  to  the
       corresponding  product  certificates  is defined in the subscrip-
       tion-manager-migration-data  package.  The  subscription-manager-
       migration-data  package must be installed before the rhn-migrate-
       classic-to-rhsm script can be run successfully.
<---SNIP--->
<---SNIP--->
       subscription-manager-migration-data.rpm
              The  package which contains the mappings for the migration
              script to migrate channels to the appropriate product cer-
              tificates.
<---SNIP--->
Version 0.3                       May 3, 2012   rhn-migrate-classic-to-rhsm(8)
[root@ibm-ls21-03 ~]# 


VERIFIED: Man page for rhn-migrate-classic-to-rhsm dictates that additional subscription-manager-migration-data must be installed.
Comment 6 errata-xmlrpc 2012-06-20 08:57:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.