Bug 811779 - subscription-manager-migration should require subscription-manager-migration-migration-data
subscription-manager-migration should require subscription-manager-migration-...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Michael Stead
: Reopened
: 915843 (view as bug list)
Depends On:
Blocks: 738066 rhsm-rhel65 rhsm-2013
  Show dependency treegraph
 
Reported: 2012-04-11 20:28 EDT by John Sefler
Modified: 2014-01-06 15:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:37:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-04-11 20:28:56 EDT
Description of problem:
Currently we have the following package dependency...

# rpm -q subscription-manager-migration-data --requires | grep subscription
subscription-manager-migration  

# rpm -q subscription-manager-migration --requires | grep subscription
subscription-manager = 0.99.14-1.el6


subscription-manager-migration-data currently requires subscription-manager-migration

Technically I think this should be reversed.  Package subscription-manager-migration-data is simply a bunch of files that get laid down on the filesystem and don't require anything special to be installed.  It's the tools inside package subscription-manager-migration that use the subscription-manager-migration-data files and are actually useless without the subscription-manager-migration-data files installed.  I propose making subscription-manager-migration require subscription-manager-migration-data.


Version-Release number of selected component (if applicable):
# rpm -q subscription-manager
subscription-manager-0.99.14-1.el6.x86_64
# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.3-1.el6.noarch
Comment 1 Alex Wood 2012-04-12 17:10:16 EDT
The dependency is weird, but was set up on purpose so that subscription-manager could be included in Fedora at some point in the future. The migration-data rpm is RH internal, and thus cannot be a dependency for subscription-manager-migration (which is built from the same source rpm as subscription-manager). We provide instructions for how a user can create their own migration data certs and mapping, in case they ever wanted to use it.
Comment 2 John Sefler 2012-04-12 18:16:51 EDT
The argument in comment 1 totally explains why subscription-manager-migration should not require subscription-manager-migration-data; fine.

Alternatively, I suggest that the dependency between these two packages be completely removed.  It's harmless to install subscription-manager-migration-data without subscription-manager-migration.
Comment 3 Alex Wood 2012-04-13 13:14:49 EDT
committed 2e3a98f59dae1ab893e48e7db81228b290e3d1b3 to RHEL 5 branch
committed 549784c326efc4e56ef95af21bb3eae1786a48b0 to RHEL 6 branch
Comment 6 Alex Wood 2012-04-24 12:19:36 EDT
Committed 0dec351333cc3ee5d2587a8c7b884ce00e06d864 on RHEL6.3 branch
Comment 8 John Sefler 2012-04-25 18:38:12 EDT
Verifying Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.5-1.el6.noarch

[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data --requires
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
[root@jsefler-r63-server ~]# 

VERIFIED: subscription-manager-migration-data no longer requires subscription-manager-migration
Comment 10 errata-xmlrpc 2012-06-20 09:37:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0823.html
Comment 11 Alex Wood 2013-03-21 16:09:50 EDT
*** Bug 915843 has been marked as a duplicate of this bug. ***
Comment 12 Robert Scheck 2014-01-06 13:57:33 EST
I can not see why this bug was closed with errata at all:

$ yum install subscription-manager-migration
[...]
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package subscription-manager-migration.x86_64 0:1.9.11-1.el6 will be installed
--> Finished Dependency Resolution
[...]

And I am sorry, I do not see how the argument from comment #1 is valid: Even
if subscription-manager gets included into Fedora, I do not see any need for
a subscription-manager-migration subpackage. There is no RHN equivalent with
CDN for Fedora. And even a subscription-manager-migration subpackage makes it 
into Fedora because of whatever reason, you still could put something like
this in the subscription-manager.spec file:

%if 0%{?rhel} >= 5
Requires: subscription-manager-migration-data
%endif
Comment 13 John Sefler 2014-01-06 15:37:41 EST
(In reply to Robert Scheck from comment #12)
Agreed.
Bug 1049037 has been newly opened to implement Robert's solution.

Note You need to log in before you can comment on or make changes to this bug.