Bug 818925 - liquibase complains: Failed to read schema document 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd'
liquibase complains: Failed to read schema document 'http://www.liquibase.org...
Status: CLOSED DUPLICATE of bug 818510
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Bryan Kearney
Eric Sammons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 07:27 EDT by Garik Khachikyan
Modified: 2015-05-14 10:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 07:55:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2012-05-04 07:27:38 EDT
Description of problem:
recent candlepin build has issues in installation. Running it inside katello fails with:

---
########## ERROR ############
Error running command: /usr/share/candlepin/cpdb --create -u candlepin --database candlepin
Status code: 256
Command output:
########## ERROR ############
Error running command: liquibase --driver=org.postgresql.Driver --classpath=/usr/share/java/postgresql-jdbc.jar:/var/lib/tomcat6/webapps/candlepin/WEB-INF/classes/ --changeLogFile=db/changelog/changelog-create.xml --url=jdbc:postgresql:candlepin --username=candlepin migrate
Status code: 65280
Command output: INFO 5/4/12 1:04 PM:liquibase: Successfully acquired change log lock
WARNING 5/4/12 1:04 PM:liquibase: schema_reference.4: Failed to read schema document 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
INFO 5/4/12 1:04 PM:liquibase: Successfully released change log lock
Liquibase Update Failed: schema_reference.4: Failed to read schema document 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
SEVERE 5/4/12 1:04 PM:liquibase: schema_reference.4: Failed to read schema document 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
liquibase.exception.ChangeLogParseException: Error parsing line 2 column 255 of db/changelog/changelog-create.xml: schema_reference.4: Failed to read schema document 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
        at liquibase.parser.core.xml.XMLChangeLogSAXParser.parse(Unknown Source)
        at liquibase.Liquibase.update(Unknown Source)
        at liquibase.integration.commandline.Main.doMigration(Unknown Source)
        at liquibase.integration.commandline.Main.main(Unknown Source)
Caused by: org.xml.sax.SAXParseException; lineNumber: 2; columnNumber: 255; schema_reference.4: Failed to read schema document 'http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-2.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:198)
        at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.warning(ErrorHandlerWrapper.java:99)
        at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:383)
        at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:321)
        at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.reportSchemaErr(XSDHandler.java:2562)
        at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.reportSchemaWarning(XSDHandler.java:2553)
        at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.getSchemaDocument(XSDHandler.java:1849)
        at com.sun.org.apache.xerces.internal.impl.xs.traversers.XSDHandler.parseSchema(XSDHandler.java:540)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaLoader.loadSchema(XMLSchemaLoader.java:564)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.findSchemaGrammar(XMLSchemaValidator.java:2441)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.handleStartElement(XMLSchemaValidator.java:1786)
        at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.startElement(XMLSchemaValidator.java:709)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:376)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDriver.scanRootElementHook(XMLNSDocumentScannerImpl.java:602)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:3080)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl$PrologDriver.next(XMLDocumentScannerImpl.java:899)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
        at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:116)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:488)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:819)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:748)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:123)
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1208)
        at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:525)
        ... 4 more


For more information, use the --logLevel flag)
Creating candlepin database
Loading candlepin schema
Traceback (most recent call last):
  File "/usr/share/candlepin/cpdb", line 126, in <module>
    dbsetup.create()
  File "/usr/share/candlepin/cpdb", line 61, in create
    self._run_liquibase("db/changelog/changelog-create.xml")
  File "/usr/share/candlepin/cpdb", line 91, in _run_liquibase
    self.username,
  File "/usr/share/candlepin/cpdb", line 32, in run_command
    error_out(command, status, output)
  File "/usr/share/candlepin/cpdb", line 40, in error_out
    raise Exception("Error running command")
Exception: Error running command
Traceback (most recent call last):
  File "/usr/share/candlepin/cpsetup", line 221, in <module>
    main(sys.argv[1:])
  File "/usr/share/candlepin/cpsetup", line 201, in main
    options.dbuser, options.db))
  File "/usr/share/candlepin/cpsetup", line 42, in run_command
    raise Exception("Error running command")
Exception: Error running command
---

Version-Release number of selected component (if applicable):
candlepin-0.5.32-1.el6.noarch
liquibase-2.0.3-4.el6.noarch
candlepin-tomcat6-0.5.32-1.el6.noarch

How reproducible:
from the first attempt

Steps to Reproduce:
1.use katello installer with epel6 candlepin fedorahosted repo + liquibase repo (http://repos.fedorapeople.org/repos/dgoodwin/liquibase/epel-6/x86_64/)
2.in the process of cpsetup failure appears.
3.look at: /var/log/katello/katello-configure/cpsetup.log 
  
Actual results:
error. Katello setup broken

Expected results:
No issues with installing candlepin

Additional info:
Comment 1 Garik Khachikyan 2012-05-04 07:31:31 EDT
hitting that *.dtd url gives me recently:
---
Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Apache/1.3.33 Server at www.liquibase.org Port 80
---

well, I don't think our whole process of installation should depend from an availability of such a dtd file~
Comment 2 Devan Goodwin 2012-05-04 07:55:16 EDT

*** This bug has been marked as a duplicate of bug 818510 ***

Note You need to log in before you can comment on or make changes to this bug.