Bug 818958 - Missing systemD unit file
Missing systemD unit file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: memcached (Show other bugs)
7.0
Unspecified Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Miroslav Lichvar
Jan Ščotka
:
Depends On: 783112
Blocks: 816135
  Show dependency treegraph
 
Reported: 2012-05-04 09:33 EDT by Alex Sersen
Modified: 2014-06-13 06:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:11:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Sersen 2012-05-04 09:33:31 EDT
Hi,

the script has marked your component with error 'missing systemD unit file'. Please review, comment and/or fix it.

Useful links:
http://fedoraproject.org/wiki/Features/SysVtoSystemd
http://fedoraproject.org/wiki/Features/systemd
Comment 1 Miroslav Lichvar 2012-05-04 09:46:26 EDT
In Fedora the request for a systemd service is in bug #783112.
Comment 2 Petr Sklenar 2012-06-21 07:41:55 EDT
hello,
I am trying 'reload-or-restart' of memcached service. And it fails.
Is it going to be fixed by this bug or that's different issue?

memcached-1.4.13-1.el7.ppc64


# systemctl status memcached.service
memcached.service - SYSV: The memcached daemon is a network memory cache service.
	  Loaded: loaded (/etc/rc.d/init.d/memcached)
	  Active: active (running) since Thu, 21 Jun 2012 20:39:12 +0900; 1s ago
	 Process: 25738 ExecStop=/etc/rc.d/init.d/memcached stop (code=exited, status=0/SUCCESS)
	 Process: 25722 ExecReload=/etc/rc.d/init.d/memcached reload (code=exited, status=0/SUCCESS)
	 Process: 25791 ExecStart=/etc/rc.d/init.d/memcached start (code=exited, status=0/SUCCESS)
	Main PID: 25796 (memcached)
	  CGroup: name=systemd:/system/memcached.service
		  └ 25796 memcached -d -p 11211 -u memcached -m 64 -c 1024 -P /var/run/memcached/memcached.pid

# systemctl reload-or-restart memcached.service
# systemctl status memcached.service
memcached.service - SYSV: The memcached daemon is a network memory cache service.
	  Loaded: loaded (/etc/rc.d/init.d/memcached)
	  Active: failed (Result: signal) since Thu, 21 Jun 2012 20:39:18 +0900; 1s ago
	 Process: 25822 ExecStop=/etc/rc.d/init.d/memcached stop (code=exited, status=0/SUCCESS)
	 Process: 25806 ExecReload=/etc/rc.d/init.d/memcached reload (code=exited, status=0/SUCCESS)
	 Process: 25791 ExecStart=/etc/rc.d/init.d/memcached start (code=exited, status=0/SUCCESS)
	Main PID: 25814 (code=killed, signal=KILL)
	  CGroup: name=systemd:/system/memcached.service
Comment 3 Miroslav Lichvar 2012-09-24 05:34:39 EDT
Yes, with the native systemd service the reload-or-restart command works.
Comment 7 Ludek Smid 2014-06-13 06:11:58 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.