Bug 950083 - Merge in the Fedora spec changes to build one single unified spec
Merge in the Fedora spec changes to build one single unified spec
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaleb KEITHLEY
:
: 954190 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-09 11:17 EDT by Kaleb KEITHLEY
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 819130
Environment:
Last Closed: 2013-07-24 13:15:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2013-04-09 11:17:19 EDT
+++ This bug was initially created as a clone of Bug #819130 +++

I'll be merging in the spec changes from Fedora. This should be used for 3.1, 3.2 and 3.3.

--- Additional comment from Vijay Bellur on 2013-02-17 22:32:16 EST ---

CHANGE: http://review.gluster.org/4454 (glusterfs.spec.in: resync with Fedora glusterfs.spec) merged in master by Anand Avati (avati@redhat.com)

--- Additional comment from Vijay Bellur on 2013-02-18 01:50:32 EST ---

CHANGE: http://review.gluster.org/4532 (LinuxRPM/Makefile: fix backquote which was triggering recursive make) merged in master by Anand Avati (avati@redhat.com)

--- Additional comment from Vijay Bellur on 2013-02-19 13:21:25 EST ---

CHANGE: http://review.gluster.org/4547 (glusterfs.spec.in: resync with Fedora glusterfs.spec) merged in master by Anand Avati (avati@redhat.com)

--- Additional comment from Vijay Bellur on 2013-03-22 14:55:24 EDT ---

CHANGE: http://review.gluster.org/4674 (glusterfs.spec.in: sync with fedora glusterfs.spec) merged in master by Anand Avati (avati@redhat.com)

--- Additional comment from Vijay Bellur on 2013-03-26 15:04:52 EDT ---

REVIEW: http://review.gluster.org/4724 (glusterfs.spec.in: resync with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2013-03-26 15:32:48 EDT ---

REVIEW: http://review.gluster.org/4725 (glusterfs.spec.in: resync with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2013-03-26 21:29:17 EDT ---

COMMIT: http://review.gluster.org/4725 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 87d03fa7f48af6500cb8277db96ee7f6c690ea1c
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Wed Feb 27 17:55:47 2013 +0530

    glusterd: Removed fd leaks in glusterfs_start utility function
    
    PROBLEM:
        The FILE* associated with the pidfile was leaked if
        pmap_registry_search on the brickinfo' path failed.
    
    FIX:
        Eliminates the use of the FILE* that was leaked. Uses
        glusterd_is_service_running utility function in place
        of the earlier attempt to check for the same.
    
    Change-Id: I94082bd5a94b8a6340f8cc11726d3264e364efe6
    BUG: 916549
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/4596
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

--- Additional comment from Vijay Bellur on 2013-03-28 11:43:13 EDT ---

REVIEW: http://review.gluster.org/4742 (glusterfs.spec.in: sync with fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2013-03-28 11:58:16 EDT ---

REVIEW: http://review.gluster.org/4743 (glusterfs.spec.in: sync with fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2013-03-28 17:28:29 EDT ---

COMMIT: http://review.gluster.org/4742 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2cd9b31a5f032af807dea7b3d1b40592444154b5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Mar 28 11:41:25 2013 -0400

    glusterfs.spec.in: sync with fedora glusterfs.spec
    
    add --without ufo
    
    Change-Id: If1b77003ded537f9664fa6ad677d48d118516c64
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    BUG: 819130
    Reviewed-on: http://review.gluster.org/4742
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

--- Additional comment from Vijay Bellur on 2013-03-28 17:28:51 EDT ---

COMMIT: http://review.gluster.org/4743 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 2cd9b31a5f032af807dea7b3d1b40592444154b5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Mar 28 11:41:25 2013 -0400

    glusterfs.spec.in: sync with fedora glusterfs.spec
    
    add --without ufo
    
    Change-Id: If1b77003ded537f9664fa6ad677d48d118516c64
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    BUG: 819130
    Reviewed-on: http://review.gluster.org/4742
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Luis Pabon <lpabon@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

--- Additional comment from Kaleb KEITHLEY on 2013-04-01 10:52:40 EDT ---

merged (cherry pick) from master to release-3.4
Comment 1 Anand Avati 2013-04-10 15:12:44 EDT
REVIEW: http://review.gluster.org/4804 (build: add BuildRequires librdmacm-devel) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2013-04-10 22:42:42 EDT
REVIEW: http://review.gluster.org/4804 (build: add BuildRequires librdmacm-devel) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Anand Avati 2013-04-12 03:22:35 EDT
COMMIT: http://review.gluster.org/4804 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2fbae10cc026c3a0dab82fdb47497f42f5683934
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Apr 10 15:08:51 2013 -0400

    build: add BuildRequires librdmacm-devel
    
    See http://review.gluster.org/149
    
    Installed librdmacm-devel RPM on the build server.
    
    Change-Id: Iafb30e9cf1b15272b80329cc6141c7e92b43daee
    BUG: 950083
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/4804
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Anand Avati 2013-04-23 12:59:12 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 5 Anand Avati 2013-04-23 13:03:16 EDT
REVIEW: http://review.gluster.org/4877 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 6 Anand Avati 2013-04-23 16:14:05 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 7 Anand Avati 2013-04-23 17:45:18 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 8 Anand Avati 2013-04-24 09:41:08 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#4) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 9 Anand Avati 2013-04-24 10:28:20 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 10 Anand Avati 2013-04-24 11:33:53 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 11 Anand Avati 2013-04-24 11:53:03 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 12 Anand Avati 2013-04-24 13:01:37 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#8) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 13 Anand Avati 2013-04-24 14:06:44 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#9) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 14 Anand Avati 2013-04-25 10:03:41 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#10) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 15 Anand Avati 2013-04-25 10:23:05 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#11) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 16 Anand Avati 2013-04-25 11:56:55 EDT
REVIEW: http://review.gluster.org/4876 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#12) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 17 Anand Avati 2013-04-26 05:38:35 EDT
COMMIT: http://review.gluster.org/4876 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 5e0116109e3c444b11adb9809c75b4da72e85457
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 23 12:57:40 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    BUG: 950083
    Change-Id: I96aeb8fbe8b79bbc058ff9a45167d822abb576ed
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/4876
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 18 Anand Avati 2013-06-07 16:21:45 EDT
REVIEW: http://review.gluster.org/5180 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 19 Anand Avati 2013-06-07 16:52:47 EDT
REVIEW: http://review.gluster.org/5180 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 20 Anand Avati 2013-06-08 09:18:38 EDT
REVIEW: http://review.gluster.org/5180 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 21 Anand Avati 2013-06-17 13:46:20 EDT
REVIEW: http://review.gluster.org/5230 (    build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 22 Anand Avati 2013-06-17 14:06:41 EDT
REVIEW: http://review.gluster.org/5230 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 23 Anand Avati 2013-06-19 10:03:25 EDT
REVIEW: http://review.gluster.org/5230 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 24 Kaleb KEITHLEY 2013-06-20 09:17:17 EDT
*** Bug 954190 has been marked as a duplicate of this bug. ***
Comment 25 Anand Avati 2013-06-21 08:50:41 EDT
REVIEW: http://review.gluster.org/5230 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#4) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 26 Anand Avati 2013-06-21 09:25:20 EDT
REVIEW: http://review.gluster.org/5230 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 27 Anand Avati 2013-06-26 07:37:22 EDT
COMMIT: http://review.gluster.org/5230 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f7b1245ca221fd7d4cee626ae358a2ebc933ffdd
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Mon Jun 17 13:44:10 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
     * add glusterfs-api and glusterfs-api-devel sub-packages
     * add extras/systemd/glusterd.service. Use it (or extras/init.d/glusterd)
       instead of the Fedora versions.
     * restores ability to build glusterfs RPMs from the dist tarball with
       'rpmbuild {-ts,-tb,-ta} glusterfs-XXX.tar.gz'
     * other minor cleanups mostly to sync with fedora .spec and to build
       from the dist tarball. Any differences will be resolved in the fedora
       .spec in the next release (i.e. beta4 or GA).
    
    (still considering whether to add fedora glusterfsd.{init,service} files
    to glusterfs or remove them from fedora.)
    
    BUG: 950083
    Change-Id: Ibda3cd57b24ef5c2a27446703e718e5044ec546c
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5230
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Bala FA <barumuga@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 28 Anand Avati 2013-06-26 07:39:39 EDT
REVIEW: http://review.gluster.org/5255 (rpm: move the mount/api xlator to the glusterfs-api sub-package) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 29 Anand Avati 2013-06-26 09:35:39 EDT
COMMIT: http://review.gluster.org/5255 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 8404ec28e4216de1783ea6fe19c79789378250a9
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed Jun 26 13:25:22 2013 +0200

    rpm: move the mount/api xlator to the glusterfs-api sub-package
    
    The main glusterfs package included the xlator/api.so file which caused
    a dependency on the glusterfs-api package:
    
      # rpm -i glusterfs-3.4.0-0.6.beta3.el6.x86_64.rpm
      error: Failed dependencies:
      libgfapi.so.0()(64bit) is needed by glusterfs-3.4.0-0.6.beta3.el6.x86_64
    
    Moving the mount/api xlator to the glusterfs-api package will prevent
    the automatic dependency generator to add the dependency to the main
    package.
    
    Change-Id: I4650c40cdfe610b9b69bab07d262093854aa6583
    BUG: 950083
    Reported-by: Vijay Bellur <vbellur@redhat.com>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/5255
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 30 Anand Avati 2013-06-27 10:46:25 EDT
REVIEW: http://review.gluster.org/5264 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 31 Anand Avati 2013-06-27 11:33:18 EDT
REVIEW: http://review.gluster.org/5264 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 32 Anand Avati 2013-06-27 11:52:09 EDT
REVIEW: http://review.gluster.org/5264 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 33 Anand Avati 2013-06-27 14:17:02 EDT
REVIEW: http://review.gluster.org/5264 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#4) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 34 Anand Avati 2013-06-28 12:23:58 EDT
COMMIT: http://review.gluster.org/5264 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit e216e2e6fcc537d7fdae4527043a2a71732c7d36
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Jun 27 10:44:44 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    * fix the hardening fix for shlibs
    * use %{__sed} macro
    * better short ChangeLog
    * fix hard-coded path in extras/systemd/glusterd.service in, use @prefix@
    
    Change-Id: I267244b68a97cbcd6f6ab62fc322c78db45023bb
    BUG: 950083
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5264
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 35 Anand Avati 2013-07-25 23:14:29 EDT
REVIEW: http://review.gluster.org/5397 (build: Add '--without bd' to disable 'bd' xlator rpmbuild) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 36 Anand Avati 2013-07-26 02:11:58 EDT
COMMIT: http://review.gluster.org/5397 committed in master by Anand Avati (avati@redhat.com) 
------
commit 115f6a679ba0117a5757fe69f8f326d633c38fbf
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Thu Jul 25 20:10:55 2013 -0700

    build: Add '--without bd' to disable 'bd' xlator rpmbuild
    
    Change-Id: I9f1774788362d8250693002318b617cd16e1a668
    BUG: 950083
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/5397
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Bala FA <barumuga@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 37 Anand Avati 2013-08-01 08:32:52 EDT
REVIEW: http://review.gluster.org/5455 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 38 Anand Avati 2013-08-02 09:57:33 EDT
REVIEW: http://review.gluster.org/5455 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 39 Anand Avati 2013-08-02 22:56:45 EDT
COMMIT: http://review.gluster.org/5455 committed in master by Anand Avati (avati@redhat.com) 
------
commit a482e4220a6c9fe2909f9d5f1b484f68deecec64
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Jul 30 14:00:46 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the master branch)
    
    * Sync with latest Fedora updates
    * add glusterfs-libs RPM for RHEL6.5 oVirt/qemu-kvm, see BZ 916645
    
    BUG: 950083
    Change-Id: If5816f9b6a9478f6663c1de4d14a9f8341da9e84
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5455
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 40 Anand Avati 2013-08-07 10:26:59 EDT
REVIEW: http://review.gluster.org/5522 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 41 Anand Avati 2013-08-08 01:23:43 EDT
COMMIT: http://review.gluster.org/5522 committed in master by Anand Avati (avati@redhat.com) 
------
commit 5fb1714c64660c69e51301f61b63e63931f85227
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Aug 7 09:11:48 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the master branch)
    
    * add necessary requires
    * add -cli subpackage
    * fix other minor differences with Fedora glusterfs.spec
    
    Change-Id: Ifd535463a68cfd0793691e37148f411b95b41867
    BUG: 950083
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5522
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 42 Anand Avati 2013-08-09 00:27:45 EDT
REVIEW: http://review.gluster.org/4797 (spec: add the alphatag global variable) posted (#3) for review on master by Anand Avati (avati@redhat.com)
Comment 43 Anand Avati 2013-10-09 08:30:24 EDT
REVIEW: http://review.gluster.org/6059 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 44 Anand Avati 2013-10-10 06:59:07 EDT
REVIEW: http://review.gluster.org/6059 (build: sync glusterfs.spec.in with Fedora glusterfs.spec) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 45 Anand Avati 2013-10-11 15:27:05 EDT
COMMIT: http://review.gluster.org/6059 committed in master by Anand Avati (avati@redhat.com) 
------
commit 6d28941b0b32ae0053604021925dfdc8d40a1047
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Oct 9 08:29:18 2013 -0400

    build: sync glusterfs.spec.in with Fedora glusterfs.spec
    
    (this is the master branch)
    
    sync with Fedora glusterfs.spec 3.4.1-2+
    
    Change-Id: I8a303efb0ac8cd3e04531e2f02427e3590387493
    BUG: 950083
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/6059
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 46 Anand Avati 2013-12-06 14:35:41 EST
REVIEW: http://review.gluster.org/6458 (build: FedoraSCM sources are not longer needed to build RPMs) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 47 Anand Avati 2013-12-06 18:32:06 EST
COMMIT: http://review.gluster.org/6458 committed in master by Anand Avati (avati@redhat.com) 
------
commit f4488e34553ec0bf68c270034af179ab14fd2b58
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Fri Dec 6 14:33:51 2013 -0500

    build: FedoraSCM sources are not longer needed to build RPMs
    
    Also some updates to .gitignore
    
    Change-Id: I576af453ca7d1ec1f3db21ee4d8386927988e7db
    BUG: 950083
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/6458
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 48 Anand Avati 2013-12-10 07:33:25 EST
REVIEW: http://review.gluster.org/6473 (build: Merge glusterfs.spec changes from Fedora) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 49 Anand Avati 2013-12-10 12:22:30 EST
REVIEW: http://review.gluster.org/6473 (build: Merge glusterfs.spec changes from Fedora) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 50 Anand Avati 2013-12-12 07:14:02 EST
REVIEW: http://review.gluster.org/6473 (build: Merge glusterfs.spec changes from Fedora) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 51 Anand Avati 2013-12-12 08:28:50 EST
REVIEW: http://review.gluster.org/6473 (build: Merge glusterfs.spec changes from Fedora) posted (#4) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 52 Anand Avati 2013-12-13 11:58:39 EST
COMMIT: http://review.gluster.org/6473 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 51a614384e694f37d957a3aa3a562c34877e71d5
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Dec 10 07:26:46 2013 -0500

    build: Merge glusterfs.spec changes from Fedora
    
    sync with FedoraSCM glusterfs.spec
    
    N.B. the %doc hack for clear_xattrs.sh doesn't work in the CentOS 5 mock
    builds of the rpm.t regression test, thus I'm leaving that out for now
    
    Change-Id: I6fa85618c916a90fdbed5b231ea58bb51c9d2b70
    BUG: 950083
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/6473
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 53 Anand Avati 2014-01-04 11:40:22 EST
REVIEW: http://review.gluster.org/6642 (build: the main glusterfs package should not provide glusterfs-libs) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 54 Anand Avati 2014-01-04 11:44:59 EST
REVIEW: http://review.gluster.org/6643 (build: the main glusterfs package should not provide glusterfs-libs) posted (#1) for review on release-3.5 by Niels de Vos (ndevos@redhat.com)
Comment 55 Anand Avati 2014-01-04 11:48:18 EST
REVIEW: http://review.gluster.org/6644 (build: the main glusterfs package should not provide glusterfs-libs) posted (#1) for review on release-3.4 by Niels de Vos (ndevos@redhat.com)
Comment 56 Anand Avati 2014-01-07 08:16:22 EST
COMMIT: http://review.gluster.org/6642 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 1e4f2d08f102e9fc1e27ffb5608d4b45c11e0b55
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sat Jan 4 17:29:26 2014 +0100

    build: the main glusterfs package should not provide glusterfs-libs
    
    Because of this incorrect provides, there is no requirement to update
    glusterfs-libs. Most users will get a newer glusterfs-libs when updating
    anyway, but users that manually select RPMs for updating my skip the
    package, which will break their system.
    
    Change-Id: I636dfac3f0a521924f1c2e82948bb513b0a5c9f9
    BUG: 950083
    Fedora-BUG: 1048489
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6642
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 57 Anand Avati 2014-01-07 08:16:39 EST
COMMIT: http://review.gluster.org/6643 committed in release-3.5 by Vijay Bellur (vbellur@redhat.com) 
------
commit a99e4e4bf576e5120dca4f2a47fb1466a8005204
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sat Jan 4 17:29:26 2014 +0100

    build: the main glusterfs package should not provide glusterfs-libs
    
    Because of this incorrect provides, there is no requirement to update
    glusterfs-libs. Most users will get a newer glusterfs-libs when updating
    anyway, but users that manually select RPMs for updating my skip the
    package, which will break their system.
    
    Change-Id: If7d73236c21de07ff7fbe32e4ba2e84910ffb98d
    BUG: 950083
    Fedora-BUG: 1048489
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6643
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 58 Anand Avati 2014-01-07 08:17:07 EST
COMMIT: http://review.gluster.org/6644 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 14f79a0b9e7a758b17e3c951bfa0150b3db0494a
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sat Jan 4 17:29:26 2014 +0100

    build: the main glusterfs package should not provide glusterfs-libs
    
    Because of this incorrect provides, there is no requirement to update
    glusterfs-libs. Most users will get a newer glusterfs-libs when updating
    anyway, but users that manually select RPMs for updating my skip the
    package, which will break their system.
    
    Change-Id: I2458ff9c993dc069baf2de8d6e99aa2ede1d5969
    BUG: 950083
    Fedora-BUG: 1048489
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6644
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.