Bug 819276 - SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory /var/lib/chrony.
SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory...
Status: CLOSED DUPLICATE of bug 768472
Product: Fedora
Classification: Fedora
Component: chrony (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-06 04:43 EDT by Roman Melihhov
Modified: 2012-08-07 07:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-07 07:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Roman Melihhov 2012-05-06 04:43:23 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.2-6.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory /var/lib/chrony.
time:           Sun 06 May 2012 11:43:12 AM EEST

:SELinux is preventing /usr/sbin/httpd from 'search' accesses on the directory /var/lib/chrony.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that httpd should be allowed search access on the chrony directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep httpd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:httpd_t:s0
:Target Context                system_u:object_r:chronyd_var_lib_t:s0
:Target Objects                /var/lib/chrony [ dir ]
:Source                        httpd
:Source Path                   /usr/sbin/httpd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           httpd-2.2.22-2.fc16.x86_64
:Target RPM Packages           chrony-1.26-5.20110831gitb088b7.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-6.fc16.x86_64 #1
:                              SMP Sat Apr 21 12:43:20 UTC 2012 x86_64 x86_64
:Alert Count                   7
:First Seen                    Fri 04 May 2012 08:39:52 PM EEST
:Last Seen                     Sun 06 May 2012 11:42:03 AM EEST
:Local ID                      c52c04a3-93d3-44bf-ad59-77e3bc3b54ce
:Raw Audit Messages
:type=AVC msg=audit(1336293723.183:82): avc:  denied  { search } for  pid=3394 comm="httpd" name="chrony" dev="sda3" ino=28776 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:chronyd_var_lib_t:s0 tclass=dir
:type=SYSCALL msg=audit(1336293723.183:82): arch=x86_64 syscall=stat success=no exit=EACCES a0=7f14718bc260 a1=7fffb00f7a20 a2=7fffb00f7a20 a3=0 items=0 ppid=1092 pid=3394 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 tty=(none) ses=4294967295 comm=httpd exe=/usr/sbin/httpd subj=system_u:system_r:httpd_t:s0 key=(null)
:Hash: httpd,httpd_t,chronyd_var_lib_t,dir,search
:#============= httpd_t ==============
:allow httpd_t chronyd_var_lib_t:dir search;
:audit2allow -R
:#============= httpd_t ==============
:allow httpd_t chronyd_var_lib_t:dir search;
Comment 1 Miroslav Grepl 2012-05-07 05:56:44 EDT
Did you setup chrony+apache together?
Comment 2 Miroslav Lichvar 2012-08-07 07:11:32 EDT

*** This bug has been marked as a duplicate of bug 768472 ***

Note You need to log in before you can comment on or make changes to this bug.