Bug 819288 - RHEVM - Backend: Bad event when adding new disk
RHEVM - Backend: Bad event when adding new disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.1.0
Assigned To: Tal Nisan
Leonid Natapov
storage
:
: 823260 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 05:55 EDT by Daniel Paikov
Modified: 2016-02-10 12:03 EST (History)
10 users (show)

See Also:
Fixed In Version: SI8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (36.95 KB, application/x-gzip)
2012-05-06 05:55 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-05-06 05:55:59 EDT
Created attachment 582423 [details]
engine.log

When adding an unattached disk via the Disks tab, the event is: "Add-Disk operation of DiskName was initiated on VM VmName by admin@internal". When adding an attached disk via the Virtual Machines tab, the event is "Add-Disk operation of DiskName was initiated on VM <vm> by admin@internal".

Since there is no VM when creating an unattached disk, this flow should have its own event text that doesn't have a VM name in it. For both events, "DiskName" should be changed to the actual disk name.
Comment 1 Yaniv Kaul 2012-05-20 07:47:41 EDT
*** Bug 823260 has been marked as a duplicate of this bug. ***
Comment 2 Tal Nisan 2012-06-20 07:56:21 EDT
http://gerrit.ovirt.org/5530
Comment 3 Leonid Natapov 2012-06-26 10:29:08 EDT
si7. not fixed. instead of "DiskName" now the event shows "DiskAlias". The same bug in different parameter.
Comment 4 Leonid Natapov 2012-07-01 10:53:34 EDT
si8. fixed.
Comment 5 Leonid Natapov 2012-07-01 10:56:42 EDT
si8. fixed.

Note You need to log in before you can comment on or make changes to this bug.