Bug 819652 - Impossible to load Windows seven installed on a second disk with Grub
Impossible to load Windows seven installed on a second disk with Grub
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 819651 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 16:47 EDT by Raphos
Modified: 2012-05-11 09:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 09:12:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Several informations (12.94 KB, text/plain)
2012-05-07 16:47 EDT, Raphos
no flags Details

  None (edit)
Description Raphos 2012-05-07 16:47:51 EDT
Created attachment 582784 [details]
Several informations

Description of problem: When i select the Windows 7 entry generated by Grub in the Grub menu at start up, i get a blinking cursor at the top left of the screen. Windows 7 is not loading.


Version-Release number of selected component (if applicable):(GRUB) 2.00~beta4 - Fedora release 17 x64 - Windows 7 Ultimate


How reproducible: Always


Steps to Reproduce:
1.Install Fedora 17 on first disk (sda).
2.Have a Windows seven installed on a second disk (sdb).
3.Choose the Windows entry in the Grub menu at start up.
  
Actual results: blinking cursor at the top left of the screen


Expected results: load Windows seven


Additional info: Windows is loading when i change the boot order in bios setup. Dual boot was working with Fedora 16.
Comment 1 Mads Kiilerich 2012-05-07 16:55:38 EDT
*** Bug 819651 has been marked as a duplicate of this bug. ***
Comment 2 Mads Kiilerich 2012-05-07 17:02:29 EDT
The short story:

/dev/sdb1: UUID="1BF579B227473E24" TYPE="ntfs" 

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sdb1)" --class windows --class os {
    insmod part_msdos
    insmod ntfs
    set root='(hd1,msdos1)'
    search --no-floppy --fs-uuid --set=root 1BF579B227473E24
    chainloader +1
}
### END /etc/grub.d/30_os-prober ###


What boot loader entry worked for dual boot with f16?


(I assume it is a windows limitation that it don't like being placed on a secondary drive without knowing it. Booting it might thus require some http://www.gnu.org/software/grub/manual/grub.html#drivemap tweaks. I doubt os-prober / grub2-mkconfig in general can know what is required.)
Comment 3 Raphos 2012-05-08 04:19:16 EDT
Unfortunately, I don't have the grub.conf from Fedora 16 anymore !

I just can tell you that I didn't change anything in what was generated by Grub for the Windows entry.

I add this entry with device map :

menuentry 'Windows_2 (loader) (on /dev/sdb1)' --class windows --class os $menuentry_id_option 'osprober-chain-1BF579B227473E24' {
	insmod part_msdos
	insmod ntfs
	set root='hd1,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos1 --hint-efi=hd1,msdos1 --hint-baremetal=ahci1,msdos1 --hint='hd1,msdos1'  1BF579B227473E24
	else
	  search --no-floppy --fs-uuid --set=root 1BF579B227473E24
	fi
	drivemap -s (hd0) (hd1)
	chainloader +1
}

but Windows doesn't start at all.
Comment 4 Mads Kiilerich 2012-05-08 06:33:22 EDT
Well ... nothing can be done here without an example of how the menu entry should look like ... or a specific example of some other boot loader that can boot windows in a setup where grub2 can't work.

Some 'parttool' tweaking might apparently also be needed in order to please windows.
Comment 5 Raphos 2012-05-11 09:01:36 EDT
Problem resolved with the Grub update : grub2.x86_64 1:2.0-0.25.beta4.fc17  @updates-testing.

Here is Grub.conf entry generated by Grub :

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 7 (loader) (sur /dev/sdb1)' --class windows --class os $menuentry_id_option 'osprober-chain-1BF579B227473E24' {
	insmod part_msdos
	insmod ntfs
	set root='hd1,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos1 --hint-efi=hd1,msdos1 --hint-baremetal=ahci1,msdos1 --hint='hd1,msdos1'  1BF579B227473E24
	else
	  search --no-floppy --fs-uuid --set=root 1BF579B227473E24
	fi
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

Windows is now loading when I choose the entry in Grub menu.
Comment 6 Mads Kiilerich 2012-05-11 09:12:29 EDT
Strange. Nothing important has changed between the first beta4 package to 0.25. But if it works for you we will close it.

Note You need to log in before you can comment on or make changes to this bug.