Bug 81975 - Can't install: IEEE-1394 SBP-2 driver (sbp2) won't load
Can't install: IEEE-1394 SBP-2 driver (sbp2) won't load
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-01-15 17:20 EST by John
Modified: 2009-02-04 09:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 21:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2003-01-15 17:20:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I am using a Sony VAIO R505G laptop.  This guy has a DVD-R/CD-RW drive in a
docking station, connected via Firewire/i.Link/IEEE-1394, or whatever you want
to call it. :)

I have successfully used this model of laptop using Red Hat Linux 8.0.  I had to
install the ohci1394, sbp2, and sr_mod kernel modules.  (Also, I used a
hand-rolled ACPI kernel...  I used stock kernel.org 2.4.20 w/ the ACPI patches.
 My recollection isn't perfect, but I don't think that ACPI was necessary to get
the drive working.)

Under Red Hat 8.0, I had to install using a harddrive install, since I was never
able to get the DVD-R drive to be recognized during the install.

I think the sbp2 driver isn't working because the ohci1394 module isn't being
installed before the sbp2 module.  Also, I don't know if the sr_mod module will
be subsequently correctly loaded.

I'd prefer it if the installation process would automatically detect the sbp2
drive, so that I would not have to use the "Select driver" screen manually. 
(Also, Red Hat 8.0's hotplug scripts didn't automatically detect the drive, so
in day-to-day usage of the drive the three modules had to be manually installed.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Under "Installation Method," choose "Local CDROM."
2. After being informed that no driver has been found, choose "Select driver."
3. Choose "IEEE-1394 SBP-2 protocol driver (sbp2)."
 

Actual Results:  Under the Alt-F4 diagnostic information screen, I see the
message "<3>ieee1394: sbp2: Please load the lower level IEEE-1394 driver (e.g.
ohci1394) before sbp2..."

Expected Results:  I expect the ochi1394, sbp2, and sr_mod modules to load
successfully, and the DVD/CD drive be recognized so that the rest of the
installation may continue.

Additional info:
Comment 1 Michael Fulbright 2003-01-16 12:10:32 EST
This appears to work now with our latest internal build.

Note we do not have the hardware to test booting from a firewire CD. But I
booted a CD with just the CD isolinux image in the IDE drive, and put a disc 1
in the firewire drive, and it was used automatically.
Comment 2 John 2003-01-16 19:03:24 EST
Ok, it seems like there is another problem with the ohci1394 driver.  I now
think that ACPI is necessary to use this firewire port and drive.  I also think
that there is a problem with Phoebe's ACPI which is preventing the firewire port
from working.

Without working ACPI, the IRQs on the machine are incorrectly configured. 
Because of this, some hardware will not work w/o ACPI...  ACPI must be working
for things like the HSF winmodem to work.  Now, it looks like it must also be
working for the ohci1394 module to be installed.  (I encountered these IRQ
issues when I previously used this model of laptop, as I alluded to above.  It
turns out that I recalled incorrectly, though, and ACPI is indeed necessary for
the firewire port to work.)

When I attempt to install the OHCI module, I get the following output on the
console:
[root@dart Kernel]# /sbin/modprobe ohci1394
/lib/modules/2.4.20-2.2/kernel/drivers/ieee1394/ohci1394.o.gz: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-2.2/kernel/drivers/ieee1394/ohci1394.o.gz: insmod
/lib/modules/2.4.20-2.2/kernel/drivers/ieee1394/ohci1394.o.gz failed
/lib/modules/2.4.20-2.2/kernel/drivers/ieee1394/ohci1394.o.gz: insmod ohci1394
failed
 
Also, the resulting output in /var/log/messages was:
Jan 16 17:16:10 dart kernel: ohci1394: $Rev: 578 $ Ben Collins <bcollins@debian.org>
Jan 16 17:16:10 dart kernel: PCI: No IRQ known for interrupt pin A of device
02:02.0. Please try using pci=biosirq.
Jan 16 17:16:10 dart kernel: ohci1394: Failed to allocate shared interrupt 0

I mentioned above that I've used this model of laptop before, using Red Hat
Linux 8.0, the stock kernel.org kernel, and the Dec. 12 ACPI patch.  With a
non-ACPI kernel, the IRQs end up being a mess; with ACPI, they work fine.  I
think the ACPI code in the Phoebe kernel isn't properly sorting out the IRQs.
(There are separate issues with the winmodem, though, so I can't figure out how
the confirm that with certainty yet.)

Let me know what other diagnostic information would be useful.  

I'm willing to try out whatever test kernels you would like to send my way. 
Also, since you don't have the hardware, if you need to test booting CDs from
firewire drives, feel free to drop me a message with a pointer to the ISOs.  I'm
very willing to test them out!!!  (This offer goes beyond Phoebe...  if you'd
occassionally like to test booting a firewire CD, let me know.)  Because of the
ACPI issues, booting on this laptop is a bit complex, but it is probably a good
test case.
Comment 3 John 2003-01-18 00:54:06 EST
Ok, the inability to install the firewire modules (ohci1394.o, etc.) is
definitely due to an ACPI problem.  I've described that problem in Bug 82147. 
Once the ACPI issue is resolved in the kernel, and folded into the boot ISOs, I
can test out the firewire boot again.
Comment 4 Brent Fox 2003-05-25 10:55:16 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.
Comment 5 John 2003-05-27 20:23:37 EDT
This bug still exists, I'm sure.  It won't be resolved until functioning ACPI is
folded into the kernel.
Comment 6 Jeremy Katz 2003-10-21 21:27:22 EDT
The rawhide kernel has acpi, you just have to boot with acpi=on to use it.
Comment 7 John 2003-10-21 22:22:35 EDT
Awesome.  I can't test the Fedora beta on the afflicted system since it is in
production use, so I'll test it when the final comes out.  I'll reopen this if
there was more necessary to the solution then just activating ACPI.  (But, I
think that should do the trick.)

Note You need to log in before you can comment on or make changes to this bug.